Last Comment Bug 647820 - Don't use -mno-cygwin on mingw compilation
: Don't use -mno-cygwin on mingw compilation
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Jacek Caban
:
Mentors:
Depends on: 662362
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-05 07:46 PDT by Jacek Caban
Modified: 2011-06-06 13:16 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (m-c part) (4.12 KB, patch)
2011-04-05 07:49 PDT, Jacek Caban
ted: review+
Details | Diff | Splinter Review
fix v1.0 (NSS part) (1.25 KB, patch)
2011-04-05 07:50 PDT, Jacek Caban
no flags Details | Diff | Splinter Review
fix v1.0 (nspr part) (1.76 KB, patch)
2011-04-05 07:50 PDT, Jacek Caban
ted: review+
wtc: review+
Details | Diff | Splinter Review

Description Jacek Caban 2011-04-05 07:46:45 PDT
This option has been deprecated for a while and now is completely removed in GCC 4.6 (causing compilation errors on an attempt to use it). What we really want is -mwindows.
Comment 1 Jacek Caban 2011-04-05 07:49:25 PDT
Created attachment 524060 [details] [diff] [review]
fix v1.0 (m-c part)
Comment 2 Jacek Caban 2011-04-05 07:50:10 PDT
Created attachment 524062 [details] [diff] [review]
fix v1.0 (NSS part)
Comment 3 Jacek Caban 2011-04-05 07:50:54 PDT
Created attachment 524063 [details] [diff] [review]
fix v1.0 (nspr part)
Comment 4 Ted Mielczarek [:ted.mielczarek] 2011-04-08 11:29:28 PDT
Comment on attachment 524062 [details] [diff] [review]
fix v1.0 (NSS part)

I'm not an NSS peer, I can't review this.
Comment 5 Jacek Caban 2011-04-11 05:34:11 PDT
Thanks for reviews!

I've pushed m-c part:
http://hg.mozilla.org/projects/build-system/rev/dd0f92e2ea92

I'm setting checkin-needed for nspr part, because AFAIU it requires special privileges.
Comment 6 Mitchell Field [:Mitch] 2011-04-19 07:43:35 PDT
http://hg.mozilla.org/mozilla-central/rev/dd0f92e2ea92
Comment 7 Boris Zbarsky [:bz] 2011-05-03 14:46:25 PDT
ted, can you land this in NSPR's CVS repo?  Or do we have someone else with that access?
Comment 8 Ted Mielczarek [:ted.mielczarek] 2011-05-04 10:34:12 PDT
I can, yes.
Comment 9 Mounir Lamouri (:mounir) 2011-05-07 01:14:52 PDT
This patch is waiting to be pushed since a month. Would be nice to have it landed before it bitrot.
Comment 10 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-05-07 04:21:26 PDT
Well, it's in NSPR, so it's unlikely to bitrot.  Only a handful of people have access to that though ... somebody should bug ted on IRC on Monday.
Comment 11 Ted Mielczarek [:ted.mielczarek] 2011-05-08 05:35:22 PDT
Sorry, after I added comment 8, I found out that NSPR trunk was frozen for a release. I can land this on Monday.
Comment 12 Ted Mielczarek [:ted.mielczarek] 2011-05-16 12:46:44 PDT
Checking in configure;
/cvsroot/mozilla/nsprpub/configure,v  <--  configure
new revision: 1.303; previous revision: 1.302
done
Checking in configure.in;
/cvsroot/mozilla/nsprpub/configure.in,v  <--  configure.in
new revision: 1.305; previous revision: 1.304
done

Well, it's *a* monday.
Comment 13 Wan-Teh Chang 2011-05-26 10:47:30 PDT
Comment on attachment 524063 [details] [diff] [review]
fix v1.0 (nspr part)

r=wtc.  This patch is in NSPR_4_8_9_BETA2.
Comment 14 Brad Lassey [:blassey] (use needinfo?) 2011-05-26 12:58:44 PDT
pushed nspr patch as part of http://hg.mozilla.org/mozilla-central/rev/b20b6d500c05
Comment 15 Jacek Caban 2011-06-06 13:16:49 PDT
Thanks for reviews and committing! I've filled bug 662362 as follow-up for NSS part.

Note You need to log in before you can comment on or make changes to this bug.