Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Maemo permaorange in content/media/test/crashtests/495794-1.html | load failed: timed out waiting for reftest-wait to be removed

RESOLVED FIXED

Status

()

Core
Audio/Video
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure})

Trunk
ARM
Maemo
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Since I don't really watch mobile tests, dunno if this is a regression, or an always-has-been. You can see from bug 573634 when I started misstarring the runs on the TraceMonkey nightlies, but I couldn't tell you whether I ignored it before then, or they didn't run before then.

http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1302088733.1302090750.8095.gz
n900-gtk tracemonkey unit crashtest on 2011/04/06 04:18:53 

REFTEST TEST-UNEXPECTED-FAIL | file:///builds/fennec/reftest/tests/content/media/test/crashtests/495794-1.html | load failed: timed out waiting for reftest-wait to be removed
REFTEST INFO | Saved log: START file:///builds/fennec/reftest/tests/content/media/test/crashtests/495794-1.html
REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering WaitForTestEnd
REFTEST INFO | Saved log: [CONTENT] WaitForTestEnd: Adding listeners
REFTEST INFO | Saved log: Initializing canvas snapshot
REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
REFTEST INFO | Saved log: [CONTENT] MakeProgress: dispatching MozReftestInvalidate
REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in file:///builds/fennec/reftest/tests/content/media/test/crashtests/495794-1.html
REFTEST INFO | Saved log: Updating canvas for invalidation
REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
REFTEST INFO | Loading a blank page
Oh, and according to m.d.planning, the Mobile tests may start reporting to mozilla-central today, in which case this and one other permaorange will result in Maemo crashtests being hidden, so we might want to hit it with a quick skip-if(browserIsRemote) hammer and then consider whether that's actually the problem.
bug 637660 disabled two tests for Android including this one:
http://hg.mozilla.org/mozilla-central/rev/2269cb1136f9

We can broaden the scope of the skip-if, but we really need to find the root cause.
My guess would be a problem with the onended event.  This test isn't failing on desktop CIPC so this might be a device-lib-specific issue.  Another possibility is that this test is just running too slowly on device.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
we should just disable these as the reftest harness will not work on this platform without fixing the harness or figuring out how to adjust the resolution on maemo.
cpearce++, fixed by bug 641718.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Depends on: 641718
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.