Closed Bug 648411 Opened 9 years ago Closed 9 years ago

about:memory doesn't account for large amounts of memory

Categories

(Core :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 563700

People

(Reporter: njn, Unassigned)

References

Details

about:memory doesn't account for large amounts of memory.  For example, after applying the patch in bug 633653, the "heap-used/other" number is usually the biggest entry in the "heap-used" tree.  (The "mapped/other" number in the "mapped" tree is also usually the biggest, though that's less important because most of it is code and data segments and thread stacks, which aren't really candidates for reduction.)

This bug is for tracking improvements in the memory reporting coverage.  Massif will be a useful tool for identifying where the unaccounted-for memory is going.
Are the dependants of bug 563700 the kind of candidates you had in mind?
Keywords: uiwanted
OS: Mac OS X → All
Hardware: x86 → All
Oh wow, I didn't know about that bug.  Thanks!
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: DarkMatter
You need to log in before you can comment on or make changes to this bug.