Last Comment Bug 640791 - (MemShrinkTools) [meta] improve memory tools as part of the MemShrink project
(MemShrinkTools)
: [meta] improve memory tools as part of the MemShrink project
Status: RESOLVED WORKSFORME
: meta
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: All All
: -- normal with 12 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 631578 (view as bug list)
Depends on: DarkMatter 579577 heap LifetimeTesting 662814 668695 340372 423032 466157 472209 521522 525288 about:compartments 629065 631637 631705 valgrind-on-tbpl revampaboutmemory 648411 648415 649532 655642 657327 661474 663416 663423 663920 669005 669116 669117 669611 670594 671159 672439 672732 DMD 677949 680482 ZombieHunter 695492
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-10 14:55 PST by Nicholas Nethercote [:njn] (on vacation until July 11)
Modified: 2012-01-26 21:59 PST (History)
38 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Nicholas Nethercote [:njn] (on vacation until July 11) 2011-03-10 14:55:00 PST
This is a companion bug to bug 640452 and bug 640457.  It's about improvements to memory measurements and benchmarking, ie. anything that helps us understand how to reduce memory consumption without actually reducing it.  Eg. bugs relating to about:memory, areweslimyet.com, specific measurements that indicate areas of improvement, etc.
Comment 1 Nicholas Nethercote [:njn] (on vacation until July 11) 2011-03-10 14:56:19 PST
*** Bug 631578 has been marked as a duplicate of this bug. ***
Comment 2 Nicholas Nethercote [:njn] (on vacation until July 11) 2011-04-12 18:43:07 PDT
Now that we have even shorter release cycles than the originally planned 3 month ones, I've changed this to be about Firefox 5 and on.  If this bug gets too unwieldy I'll close it out and start a new one.
Comment 3 Nicholas Nethercote [:njn] (on vacation until July 11) 2011-06-13 19:19:42 PDT
I'm renaming this from "mprof-fx5+" to "mtools-fx5+", to broaden its scope to cover any kinds of tools related to the measuring, tracking and/or reduction of memory usage.
Comment 4 Nicholas Nethercote [:njn] (on vacation until July 11) 2011-07-24 22:59:05 PDT
Renaming again to "MemShrinkTools", to reflect the fact that this tracking is for the MemShrink project.
Comment 5 Nicholas Nethercote [:njn] (on vacation until July 11) 2012-01-06 18:15:45 PST
Does anyone care if we close this bug?  I certainly wouldn't.

Note You need to log in before you can comment on or make changes to this bug.