Last Comment Bug 648483 - Image doesn't successfully redraw on full page scroll, instead gets covered by nearby content..
: Image doesn't successfully redraw on full page scroll, instead gets covered b...
Status: VERIFIED FIXED
: regression
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: mozilla6
Assigned To: Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
:
Mentors:
Depends on:
Blocks: 625288 649557
  Show dependency treegraph
 
Reported: 2011-04-07 21:51 PDT by Nathan Hammond
Modified: 2013-12-27 14:35 PST (History)
7 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Image of what it looks like. (29.92 KB, image/png)
2011-04-07 21:52 PDT, Nathan Hammond
no flags Details
reduced testcase (1.57 KB, text/html)
2011-04-12 16:22 PDT, Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
no flags Details
fix (12.55 KB, patch)
2011-04-12 22:13 PDT, Robert O'Callahan (:roc) (Exited; email my personal email if necessary)
tnikkel: review+
asa: approval‑mozilla‑aurora-
Details | Diff | Review

Description Nathan Hammond 2011-04-07 21:51:07 PDT
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

http://android-gripes.tumblr.com/post/4409289546/why-do-apps-from-the-same-company-look-worse-on-android

fn-right arrow (end)
fn-left arrow (home)

Observe the top header.

Reproducible: Always
Comment 1 Nathan Hammond 2011-04-07 21:52:37 PDT
Created attachment 524572 [details]
Image of what it looks like.
Comment 2 Alice0775 White 2011-04-07 23:50:52 PDT
Confirmed on
http://hg.mozilla.org/mozilla-central/rev/fb566937c787
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110407 Firefox/4.2a1pre ID:20110407030522

Regression window(cached m-c hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/94481eaabdaf
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110115 Firefox/4.0b10pre ID:20110116092902
Fails:
http://hg.mozilla.org/mozilla-central/rev/3f8ae66d0015
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110115 Firefox/4.0b10pre ID:20110116135255
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=94481eaabdaf&tochange=3f8ae66d0015
Comment 3 Alice0775 White 2011-04-08 02:06:45 PDT
In local build:
build from 4ed9ac3db848 : fails
build from 653d6fb3e557 : works
build from 74c7d5446b36 : works
build from 8d8b99147753 : works
Triggered by:
4ed9ac3db848	Robert O'Callahan — Bug 625288. Part 2: Report that -moz-win-glass and -moz-win-borderless-glass are uniform with opacity 0, i.e. they don't paint anything. Skip such display items when accumulating the visible region of a layer. r=tnikkel,a=blocking
Comment 4 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-04-09 16:00:03 PDT
Works for me on Windows 7 with and without acceleration :-(
Comment 5 Alice0775 White 2011-04-09 20:27:44 PDT
*In addition to comment #2
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/7d90da136b2c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110409 Firefox/4.2a1pre ID:20110409030509
Graphics
  Adapter Description: ATI Radeon HD 4300/4500 Series
  Vendor ID: 1002
  Device ID: 954f
  Adapter RAM: 512
  Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  Driver Version: 8.831.2.0
  Driver Date: 3-8-2011
  Direct2D Enabled: true
  DirectWrite Enabled: true (6.1.7601.17563, font cache n/a)
  WebGL Renderer: Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
  GPU Accelerated Windows: 1/1 Direct3D 10

*It does not happen if layers.acceleration.disabled = true

*It also happens WundowsXP on VMware if layers.acceleration.force-enabled = true.
(Guest OS: WindowsXP Sp3,Host OS:Windows7 Sp1).
http://hg.mozilla.org/mozilla-central/rev/7d90da136b2c
Mozilla/5.0 (Windows NT 5.1; rv:2.2a1pre) Gecko/20110409 Firefox/4.2a1pre ID:20110409030509
Graphics
  Adapter Description : VMware SVGA II
  Vendor ID : 15ad
  Device ID : 0405
  Adapter RAM : Unknown
  Adapter Drivers : vmx_fb
  Driver Version : 11.6.0.35
  Driver Date : 4-21-2010
  Direct2D Enabled : Blocked on your graphics card because of unresolved driver issues.
  DirectWrite Enable : false (0.0.0.0, font cache n/a)
  WebGL Renderer : (WebGL unavailable)
  GPU Accelerated Windows : 1/1 Direct3D 9
Comment 6 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-04-12 14:28:54 PDT
I can reproduce this now!
Comment 7 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-04-12 16:22:36 PDT
Created attachment 525544 [details]
reduced testcase

This reduced testcase reproduces the bug.
Comment 8 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-04-12 22:13:09 PDT
Created attachment 525619 [details] [diff] [review]
fix
Comment 9 Timothy Nikkel (:tnikkel) 2011-05-12 15:56:49 PDT
Comment on attachment 525619 [details] [diff] [review]
fix

diff --git a/layout/reftests/scrolling/layer-change-1-ref.html b/layout/reftests/scrolling/layer-change-1-ref.html
+<iframe style="margin-top:100px; width:100%; height:600px;" src="android-frame.html"></iframe>

android-frame.html should be layer-change-1-frame.html I think. Same for the other test file.

@@ -1120,16 +1124,18 @@ ContainerState::ThebesLayerData::Accumul
+  } else {
+    printf("HUH?");
   }

This seems unintended.
Comment 10 Mounir Lamouri (:mounir) 2011-05-17 06:37:07 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/612ba83f4289
Comment 11 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-05-17 22:31:30 PDT
Comment on attachment 525619 [details] [diff] [review]
fix

This is visual regression in Firefox 4 that I think we should fix ASAP.
Comment 12 Asa Dotzler [:asa] 2011-05-18 23:45:06 PDT
roc, we're into Beta now, where we'd hoped to be down to only very safe changes. What's the risk here?
Comment 13 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-05-19 02:11:31 PDT
It's not a trivial patch, but it's not deep either. Hard to quantify.

Given the lack of dups and dependencies, maybe we should just leave this one out.
Comment 14 Vlad [QA] 2011-07-28 07:07:30 PDT
Setting resolution to Verified Fixed on Mozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0

Note You need to log in before you can comment on or make changes to this bug.