right-click which cancels a context menu doesn't focus link

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: jruderman, Assigned: saari)

Tracking

Trunk
mozilla1.0
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
1. Open http://www.mozilla.org/
2. Right-click on a link.
3. With the context menu still up, right-click on another link.

The second link should be focused.  Note that "open link in new window" 
correctly opens the second link.

Comment 1

18 years ago
Yep, I'm seeing this as well, using a brand new build.  I don't think this is a
new problem, though.

Comment 2

18 years ago
Whaddya know?  A side-effect of my suggested fix to bug 30841 is that it fixes
this bug as well.  Marking this bug dependent on that one.

There appear, however, to be some underlying problems with right-clicking
focusing links.  For example, if I right-click on a link in the footer on the
Bugzilla query page, it never receives the focus rectangle.
Depends on: 30841

Comment 3

18 years ago
Fix for 30841 doesn't fix this for me...?

Comment 4

18 years ago
Really?  Odd.  I did the following with the "else if" and I got the symptoms 
described in the bug, and then with the "if" and it worked as expected.

1. Open www.mozilla.org.
2. Right-click on "Get Involved"
3. Right-click on "Feedback" right above that.

The "Feedback" link gets the focus rect.

Note that not all links seem to be focussing on a click, like the "more..." 
links, and the "The Mozilla Organization", "Developer Docs", "Testing", "Tools", 
"FAQ", and "Search" links.  But these never focus on a right-click, so that's a 
different bug.

Comment 5

18 years ago
Nope, doesn't work for me...
(Reporter)

Comment 6

18 years ago
This isn't a recent regression.  Hixie mentioned it in September in bug 52311, 
and I found that bug while searching for this one.  (Bug 52311 might also be 
related to why right-clicking bold or italic links on www.mozilla.org never 
focuses them.)

Comment 7

18 years ago
cc: pink and saari

Any chance either of you could try this sometime and report what you get?

Comment 8

18 years ago
Just re-pulled everything and built from scratch.  Confirmed that the bug 
existed as reported.  Made the change I suggest in 30841.  Works as expected.

Win2000 sp1
(Reporter)

Comment 9

18 years ago
This isn't specific to links, by the way.  The same should happen for any 
object that takes focus when right-clicked.

Comment 10

18 years ago
Yeah, there's another bug somewhere about some things not getting focus when 
you right-click them.  But my fix to bug 30841 makes sure that anything that 
takes focus on a single right-click works under the conditions described in 
this bug.
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 12

18 years ago
qa contact updated.
QA Contact: gerardok → bsharma

Comment 13

18 years ago
changing the component to 'Layout'.
Assignee: clayton → karnaze
Component: HTML Element → Layout
QA Contact: bsharma → petersen
Target Milestone: --- → mozilla0.8.1

Comment 14

18 years ago
Reassigning to Saari. This looks like a focus issue, so I'm not sure why it was 
reassigned to layout.
Assignee: karnaze → saari
(Assignee)

Comment 15

18 years ago
Late to the game, I just saw this... so no 8.1

Plus, right clicking for focus is really low on the priority totem pole. Moving
to 1.0
Status: NEW → ASSIGNED
Target Milestone: mozilla0.8.1 → mozilla1.0

Comment 16

18 years ago
I think I'm really close in 30841, I just haven't had time to go back in and
hammer out the regression it causes.

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 17

18 years ago
This is working for me in 2001061804 on Win32.

1. Open www.mozilla.org
2. Right-click "At A Glance" (under "The Mozilla Organization")
3. Right-click "Feedback".

Expected and Actual Results: "Feedback" link is focused

Marking WFM.

Note: There are other bugs for right-clicking not focusing links such as "The 
Mozilla Organization" and the various "more..." links.
You need to log in before you can comment on or make changes to this bug.