Bump up max HTTP proxy connection limits

RESOLVED FIXED in mozilla18

Status

()

Core
Networking: HTTP
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: jduell, Assigned: mcmanus)

Tracking

unspecified
mozilla18
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

We currently set network.http.max-persistent-connections-per-proxy to 8:

http://mxr.mozilla.org/mozilla-central/source/modules/libpref/src/init/all.js#712

Chrome sets the analogous number to 32:

   http://tinyurl.com/3es2a9x

When we're not using persistent proxy connections, it looks like we use the same limit for proxies as we do for hosts (network.http.max-connections-per-server), set to 15:

  http://mxr.mozilla.org/mozilla-central/source/modules/libpref/src/init/all.js#702

We may want to split out a separate pref for that and use a higher number for proxies?  (or just have a single max-proxy-connections setting for both persistent/non-persistent, as Chrome seems to be using).
(Assignee)

Comment 1

6 years ago
Created attachment 657569 [details] [diff] [review]
patch 0

I've updated the desktop proxy limit to 32.

I've updated b2g connection limits to match the fennec ones we updated a couple months ago.. specifically up to 6 per host and 20 overall.

I've also updated the mobile and b2g proxy limit to 20, which matches their total connection limit.
Attachment #657569 - Flags: review?(jduell.mcbugs)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 364443
(Assignee)

Updated

5 years ago
Duplicate of this bug: 490707
(Reporter)

Comment 4

5 years ago
Comment on attachment 657569 [details] [diff] [review]
patch 0

Review of attachment 657569 [details] [diff] [review]:
-----------------------------------------------------------------

::: b2g/app/b2g.js
@@ +44,5 @@
>  pref("network.http.proxy.pipelining", true);
>  pref("network.http.pipelining.maxrequests" , 6);
>  pref("network.http.keep-alive.timeout", 600);
> +pref("network.http.max-connections", 20);
> +pref("network.http.max-persistent-connections-per-server", 6);

These are nice to have for B2G, assuming they work well.  I'm +r-ing on the assumption that we'll have a plan to evaluate that they do indeed improve perf.

::: mobile/xul/app/mobile.js
@@ +88,5 @@
>  pref("network.http.pipelining.maxrequests" , 6);
>  pref("network.http.keep-alive.timeout", 600);
>  pref("network.http.max-connections", 6);
>  pref("network.http.max-persistent-connections-per-server", 4);
> +pref("network.http.max-persistent-connections-per-proxy", 6);

might as well be 20, like rest of mobile/b2g?   That said mobile-xul is probably going away soon, so not really an issue.
Attachment #657569 - Flags: review?(jduell.mcbugs) → review+
(Reporter)

Comment 5

5 years ago
cjones/dietrich/dougt:  so this patch will also raise HTTP max-simultaneous connnections from 6 to 20, which should be a win provided the larger # of sockets/etc doesn't cause some sort of issue.  Any chance we could get someone with an Otero device to sanity-check that bumping up these prefs (can set in about:config: network.http.max-connections and network.http.max-persistent-connections-per-proxy) does indeed help?
(Assignee)

Comment 6

5 years ago
thanks jason - these changes recently benefited android.. the old inherited mobile values are about 4 years out of date now, so b2g should minimally ride that curve imo.
(Assignee)

Comment 7

5 years ago
I gave mobile-xul {20,6,20} for consistency with android in case anyone wants to run it.

https://hg.mozilla.org/integration/mozilla-inbound/rev/f2bc7b6958cd
https://hg.mozilla.org/mozilla-central/rev/f2bc7b6958cd
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
Created attachment 658786 [details] [diff] [review]
patch to httpd.js to increase maxConnections

I'm going to land this pending review, to fix the problems described in the commit message within the patch.
Attachment #658786 - Flags: review?(jwalden+bmo)
Attachment #658786 - Flags: review?(jwalden+bmo) → review+
You need to log in before you can comment on or make changes to this bug.