Last Comment Bug 648741 - Entire window is black with hardware acceleration enabled on Linux
: Entire window is black with hardware acceleration enabled on Linux
Status: VERIFIED FIXED
: regression
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Matt Woodrow (:mattwoodrow)
:
: Milan Sreckovic [:milan]
Mentors:
: 650362 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-09 05:26 PDT by Blair McBride [:Unfocused] (UNAVAILABLE)
Modified: 2011-06-11 01:06 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshot (107.64 KB, image/png)
2011-04-14 15:33 PDT, Wil Clouser [:clouserw]
no flags Details
Make our scoped texture binds actually hold while we draw (1.73 KB, patch)
2011-04-17 21:49 PDT, Matt Woodrow (:mattwoodrow)
jacob.benoit.1: review+
Details | Diff | Splinter Review

Description Blair McBride [:Unfocused] (UNAVAILABLE) 2011-04-09 05:26:05 PDT
Just updated to the latest linux64 nightly, and the entire client area of the window is black. The window has borders, and resizing doesn't make any difference (not even any flickering).

Using the following build:

Mozilla/5.0 (X11; Linux x86_64; rv:2.2a1pre) Gecko/20110409 Firefox/4.2a1pre
(Built from http://hg.mozilla.org/mozilla-central/rev/7d90da136b2c)

With layers.acceleration.force-enabled set to true.

Graphics driver: NVidia 270.29
Graphics card: Quadro FX 880M
Comment 1 Wil Clouser [:clouserw] 2011-04-13 22:07:51 PDT
Same here using the 32 bit version of today's nightly: Mozilla/5.0 (X11; Linux i686; rv:6.0a1) Gecko/20110413 Firefox/6.0a1

Graphics driver: nVidia 260.19.06
Graphics card: nVidia Corporation G92 [GeForce GTS 250] (rev a2)
Comment 2 Blair McBride [:Unfocused] (UNAVAILABLE) 2011-04-14 05:54:39 PDT
I forgot to check again before I upgraded my graphics drivers, but everything is working again with the latest beta driver from NVidia (270.41.03).
Comment 3 Blair McBride [:Unfocused] (UNAVAILABLE) 2011-04-14 05:56:58 PDT
(In reply to comment #2)
> I forgot to check again before I upgraded my graphics drivers, but everything
> is working again with the latest beta driver from NVidia (270.41.03).

Er, sorry, ignore this - I accidentally ran an old build. 

270.41.03 still exhibits a totally black window on the latest nightly (20110414).
Comment 4 Matt Woodrow (:mattwoodrow) 2011-04-14 15:24:05 PDT
This was fixed in a follow-up to bug 640082.

*** This bug has been marked as a duplicate of bug 640082 ***
Comment 5 Wil Clouser [:clouserw] 2011-04-14 15:33:45 PDT
Created attachment 526122 [details]
screenshot

That bug was fixed 2 days ago and using today's nightly I still can reproduce this (Mozilla/5.0 (X11; Linux i686; rv:6.0a1) Gecko/20110414 Firefox/6.0a1).  In fact, if I enable it my menu's turn black before I even restart.  Clicking the menu and tooltips still work as expected.

I don't think this bug is fixed.
Comment 6 Wil Clouser [:clouserw] 2011-04-15 00:02:26 PDT
Reopening so it doesn't get lost.  If the other bug is committing to a branch or something, let me know.
Comment 7 Blair McBride [:Unfocused] (UNAVAILABLE) 2011-04-15 02:37:05 PDT
Confirming: bug still present on latest nightly (same build as comment 5).
Comment 8 Matt Woodrow (:mattwoodrow) 2011-04-17 21:49:38 PDT
Created attachment 526654 [details] [diff] [review]
Make our scoped texture binds actually hold while we draw

Apologies, I thought we had verified this as fixed by the previous patch.

This fixes the problem for me, hopefully this was the only issue.
Comment 9 Matt Woodrow (:mattwoodrow) 2011-04-18 16:12:49 PDT
http://hg.mozilla.org/mozilla-central/rev/3a8ab199da98
Comment 10 Daniel Cater 2011-04-19 05:25:18 PDT
Confirming fixed for me (Nvidia 260.19.06). Is there a tracking bug for getting layers acceleration enabled by default on Linux? There are still a few visual glitches, but autoscrolling gets so much faster!
Comment 11 Wil Clouser [:clouserw] 2011-04-19 08:19:36 PDT
Also fixed for me
Comment 12 Benoit Jacob [:bjacob] (mostly away) 2011-04-20 07:14:14 PDT
Daniel: you may want to look at the blockers of bug 640082, plus bug 645407.
Comment 13 Benoit Jacob [:bjacob] (mostly away) 2011-04-20 07:14:58 PDT
*** Bug 650362 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.