comhome.comdirect.de is not TLS aware

VERIFIED FIXED in psm2.0

Status

P1
major
VERIFIED FIXED
18 years ago
2 years ago

People

(Reporter: siebert, Assigned: javi)

Tracking

1.0 Branch
psm2.0
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Hello,
the site http://comhome.comdirect.de is the major online broker
here in Germany. So many users might want to access this site,but
using mozilla 0.7 you can't.
You get the following errors:

sh: invalid character 17 in exportstr for AVA_PLUGIN_STATE130_01
./start-psm: invalid character 17 in exportstr for AVA_PLUGIN_STATE130_01
Error loading URL http://comhome.comdirect.de/: 80004005

Bye

Comment 1

18 years ago
Unfortunately comdirect doesn't work with TLS enabled. Please go to the PSM,
then "Advanced ... Options", disable TLS and try again. Does it work now?
Then it may be a dup of bug 33772, although that one is marked windows only.

But unfortunately even after doing that you still can't log in. That would be
bug 48453.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
Marking invalid. Comdirect is using a TLS intolerant server. Until they fix 
their server, the workaround for the client is descibed above.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Updated

18 years ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: mozilla stops loading the page → comhome.comdirect.de is not TLS aware

Comment 3

18 years ago
I also filed this bug before, and you marked it as invalid, too. But I'm not
quite satisfied with this practise. I have seen that other bugs of this kind
have been kept open and assigned to the component "Evangelism". Does that not
apply to PSM?

I'm sure this won't be the last time this bug will be reported. Wouldn't it be
better if it would stay open (at component Evangelism) so that others can find
it instead of filing it again?

And why do you mark it invalid? It is very easy to confirm. It may be a dup of
some other bug, but invalid?

And another question: you resolved bug 57640 which I submitted about this *and*
verified that yourself. Is this common practise? I thought the point with
verifying something would be that someone *else* does this.

CCing Evangelism owners, I hope they can help here. Reopening and changing
summary.

Comment 4

18 years ago
Let's give it a try - over to evangelism.
I marked this bug invalid because there is nothing wrong with PSM in this 
regard, and there is an easy solution - turn off TLS. As an employee at 
Netscape, I can mark bugs verified where I also resolved them. If I didn't, 99% 
of the bugs assigned to me as QA Contact would not get verified.
Component: Client Library → Evangelism
Product: PSM → Browser
Version: 1.01 → other

Comment 5

18 years ago
Reassigning to evangelism@telocity.com
Assignee: ddrinan → evangelism
Status: REOPENED → NEW
QA Contact: junruh → zach

Comment 6

18 years ago
Verifying bugs that you resolved is fine if you're the QA contact.  But the 
justification for that is that you're the QA contact, not that you're an 
employee of Netscape.

Comment 7

18 years ago
I did disable TLS it does not solve the problem.

I get the same error for these two pages:

Error loading URL http://comhome.comdirect.de/: 80004005
Error loading URL https://webbanking.tdaccess.com/: 80004005

Comment 8

18 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary
*** Bug 79360 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Component: Evangelism → Client Library
Product: Browser → PSM
Target Milestone: --- → 2.0
Version: other → 2.0
(Assignee)

Comment 10

18 years ago
->psm, p1
Priority: -- → P1
(Assignee)

Comment 11

18 years ago
taking bug
Assignee: bclary → javi
(Assignee)

Comment 12

18 years ago
Created attachment 37220 [details] [diff] [review]
patch to use SSL v3.0 when SSL v3.1 (TLS) fails.
(Assignee)

Comment 13

18 years ago
wtc:
Please review my patch.
(Assignee)

Comment 14

18 years ago
Created attachment 37374 [details] [diff] [review]
Updated patch
(Assignee)

Comment 15

18 years ago
r=wtc, via e-mail.
Sending to blizzard for sr=
(Assignee)

Comment 16

18 years ago
Created attachment 37380 [details] [diff] [review]
Latest patch w/ updates suggested by wtc.
(Assignee)

Comment 17

18 years ago
Ignore the section of the patch for nsSecureBrowserUIImpl.cpp.

I forgot to remove that from the patch when I patched the entire directory.

Comment 18

18 years ago
I reviewed Javi's change and his latest patch incorporated
my suggested changes.  r=wtc.
sr=blizzard

Comment 20

18 years ago
a= asa@mozilla.org for checkin to the trunk.
(on behalf of drivers)
(Assignee)

Comment 21

18 years ago
Fix checked into the trunk.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 22

18 years ago
*** Bug 83630 has been marked as a duplicate of this bug. ***

Comment 23

18 years ago
Verified with the 6/11 trunk build.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

10 years ago
Version: psm2.0 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.