Last Comment Bug 649127 - Intermittent timeout in browser/base/content/test/tabview/browser_tabview_rtl.js | application timed out after 330 seconds with no output
: Intermittent timeout in browser/base/content/test/tabview/browser_tabview_rtl...
Status: RESOLVED FIXED
: intermittent-failure
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal
: Firefox 6
Assigned To: Tim Taubert [:ttaubert]
:
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2011-04-11 14:18 PDT by :Ehsan Akhgari (busy, don't ask for review please)
Modified: 2016-04-12 14:00 PDT (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch v1 (2.21 KB, patch)
2011-04-12 11:50 PDT, Tim Taubert [:ttaubert]
ehsan: review+
raymond: feedback+
Details | Diff | Review
patch for checkin (2.48 KB, patch)
2011-04-13 13:17 PDT, Tim Taubert [:ttaubert]
no flags Details | Diff | Review

Description :Ehsan Akhgari (busy, don't ask for review please) 2011-04-11 14:18:09 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1302552420.1302554125.28131.gz
Rev3 WINNT 5.1 mozilla-central opt test mochitest-other on 2011/04/11 13:07:00

TEST-START | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_rtl.js
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_rtl.js | Tab View starts hidden
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_rtl.js | application timed out after 330 seconds with no output
INFO | automation.py | Application ran for: 0:08:59.469000
INFO | automation.py | Reading PID log: c:\docume~1\cltbld\locals~1\temp\tmpjhejuppidlog
==> process 252 launched child process 1392
INFO | automation.py | Checking for orphan process with PID: 1392
Comment 1 Tim Taubert [:ttaubert] 2011-04-12 11:50:45 PDT
Created attachment 525457 [details] [diff] [review]
patch v1
Comment 2 Raymond Lee [:raymondlee] 2011-04-12 12:16:38 PDT
Comment on attachment 525457 [details] [diff] [review]
patch v1

Do you know what's the cause of the problem? Is that because tabViewCommand.doCommand() is not reliable?
Comment 3 Tim Taubert [:ttaubert] 2011-04-12 12:21:24 PDT
The doCommand() does fail sometimes. Maybe when the window lost its focus? AFAIK there was some other test that was failing intermittently because of this, right? I just figured that this test doesn't really need to trigger the command directly :)
Comment 4 :Ehsan Akhgari (busy, don't ask for review please) 2011-04-12 17:45:12 PDT
We can use waitForFocus to make sure that the test window is focused, if that's necessary.
Comment 5 Tim Taubert [:ttaubert] 2011-04-12 17:48:14 PDT
(In reply to comment #4)
> We can use waitForFocus to make sure that the test window is focused, if that's
> necessary.

Yeah I know, from your docs about intermittently failing tests :) But IMHO we don't really need to test here if the command is working because that test is about LTR/RTL.
Comment 6 Raymond Lee [:raymondlee] 2011-04-12 19:47:15 PDT
Comment on attachment 525457 [details] [diff] [review]
patch v1

Looks good.
Comment 7 :Ehsan Akhgari (busy, don't ask for review please) 2011-04-12 21:19:26 PDT
Comment on attachment 525457 [details] [diff] [review]
patch v1

r=me as the author of the test, and someone who wants our orange bugs to get fixed ASAP!
Comment 8 Tim Taubert [:ttaubert] 2011-04-13 13:17:49 PDT
Created attachment 525781 [details] [diff] [review]
patch for checkin

Passed try (kind of):

http://tbpl.mozilla.org/?tree=MozillaTry&pusher=tim.taubert@gmx.de&rev=a581302952b1
Comment 9 :Ehsan Akhgari (busy, don't ask for review please) 2011-04-14 11:32:46 PDT
http://hg.mozilla.org/projects/cedar/rev/a51ecdeca4a8
Comment 10 :Ehsan Akhgari (busy, don't ask for review please) 2011-04-15 07:00:00 PDT
http://hg.mozilla.org/mozilla-central/rev/a51ecdeca4a8

Note You need to log in before you can comment on or make changes to this bug.