Last Comment Bug 649367 - "nightly is up to date" does not have enough contrast against the new about window dark backgrounds
: "nightly is up to date" does not have enough contrast against the new about w...
Status: VERIFIED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: Firefox 6
Assigned To: :Margaret Leibovic
:
Mentors:
Depends on:
Blocks: 648362
  Show dependency treegraph
 
Reported: 2011-04-12 09:33 PDT by Kyle Huey [:khuey] (khuey@mozilla.com)
Modified: 2011-04-24 00:26 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch to make text white (924 bytes, patch)
2011-04-12 16:20 PDT, :Margaret Leibovic
gavin.sharp: review+
Details | Diff | Review

Description Kyle Huey [:khuey] (khuey@mozilla.com) 2011-04-12 09:33:16 PDT

    
Comment 1 Wes Kocher (:KWierso) 2011-04-12 09:38:35 PDT
Maybe needs an outline/background like the alt-toggled menu bar on Win7 with Aero?
Comment 2 Marco Bonardo [::mak] 2011-04-12 15:47:56 PDT
A text-shadow could also work, fwiw this is not a text that needs high readability.
Btw, I think a better bug to block against is probably bug 648362 that added the new dark backgrounds, the icons by themselves don't cause issues.
Comment 3 :Margaret Leibovic 2011-04-12 16:20:50 PDT
Created attachment 525543 [details] [diff] [review]
patch to make text white

This patch just makes the text white. I don't think we need to be doing anything complicated here, just ensuring it's readable is a sufficient solution, especially since this only affects nightly/aurora builds.
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-04-12 19:43:34 PDT
Comment on attachment 525543 [details] [diff] [review]
patch to make text white

Should someone ui-review this? I'm OK with it visually, which is reason for worry.
Comment 5 Alex Limi (:limi) — Firefox UX Team 2011-04-12 20:58:39 PDT
LGTM.
Comment 6 Mounir Lamouri (:mounir) 2011-04-18 16:34:11 PDT
Pushed in cedar:
http://hg.mozilla.org/projects/cedar/rev/8794c0df7997
Comment 7 Mounir Lamouri (:mounir) 2011-04-19 03:04:39 PDT
Pushed in m-c:
http://hg.mozilla.org/mozilla-central/rev/8794c0df7997
Comment 8 AndreiD[QA] 2011-04-22 05:02:37 PDT
Verified on

Win7: 
Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110421 Firefox/6.0a1

Win XP:
Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110421 Firefox/6.0a1 

Linux:
Mozilla/5.0 (X11; Linux i686; rv:6.0a1) Gecko/20110421 Firefox/6.0a1

Mac 10.6:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a1) Gecko/20110421
Firefox/6.0a1

Note You need to log in before you can comment on or make changes to this bug.