Last Comment Bug 649381 - implement moz-icon android support
: implement moz-icon android support
Status: VERIFIED FIXED
: verified-aurora
Product: Core
Classification: Components
Component: Widget: Android (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla7
Assigned To: Alex Pakhotin (:alexp)
:
: Jim Chen [:jchen] [:darchons]
Mentors:
: 518361 611334 (view as bug list)
Depends on:
Blocks: 647338
  Show dependency treegraph
 
Reported: 2011-04-12 09:56 PDT by Brad Lassey [:blassey] (use needinfo?)
Modified: 2013-02-13 21:29 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
7+


Attachments
[WIP] Stub decoder (11.60 KB, patch)
2011-06-06 13:33 PDT, Alex Pakhotin (:alexp)
no flags Details | Diff | Splinter Review
[WIP] libxul-config.mk change (634 bytes, patch)
2011-06-07 16:19 PDT, Alex Pakhotin (:alexp)
no flags Details | Diff | Splinter Review
Fix (23.71 KB, patch)
2011-06-14 16:55 PDT, Alex Pakhotin (:alexp)
blassey.bugs: review+
Details | Diff | Splinter Review
Fix v2 (23.24 KB, patch)
2011-06-16 18:13 PDT, Alex Pakhotin (:alexp)
alex.mozilla: review+
Details | Diff | Splinter Review

Description Brad Lassey [:blassey] (use needinfo?) 2011-04-12 09:56:37 PDT

    
Comment 1 Brad Lassey [:blassey] (use needinfo?) 2011-05-10 13:52:08 PDT
*** Bug 611334 has been marked as a duplicate of this bug. ***
Comment 2 Brad Lassey [:blassey] (use needinfo?) 2011-05-13 11:41:24 PDT
*** Bug 518361 has been marked as a duplicate of this bug. ***
Comment 3 Alex Pakhotin (:alexp) 2011-06-06 13:33:00 PDT
Created attachment 537625 [details] [diff] [review]
[WIP] Stub decoder

Just an empty decoder module to see if it's hooked up properly.
Comment 4 Alex Pakhotin (:alexp) 2011-06-07 16:19:45 PDT
Created attachment 537898 [details] [diff] [review]
[WIP] libxul-config.mk change

One more bit, which actually enables the icon decoder component for Android.
Comment 5 Alex Pakhotin (:alexp) 2011-06-14 16:55:28 PDT
Created attachment 539368 [details] [diff] [review]
Fix

The patch includes
- Java function to get the icon for a specific file extension
- AndroidBridge and IPC bits to call the Java code
- nsIconChannel decoder implementation for Android in libpr0n
- makefiles/config changes to use a proper theme and include the new decoder code in Android build
Comment 6 Brad Lassey [:blassey] (use needinfo?) 2011-06-16 06:16:08 PDT
Comment on attachment 539368 [details] [diff] [review]
Fix

Review of attachment 539368 [details] [diff] [review]:
-----------------------------------------------------------------

r=blassey assuming the theme change isn't required

::: configure.in
@@ -4850,5 @@
>          NSS_DISABLE_DBM=1
>          USE_ARM_KUSER=1
>          MOZ_INSTALLER=
>          NECKO_WIFI=
> -        MOZ_THEME_FASTSTRIPE=1

I don't think this change is needed, can you confirm and remove? or explain why its required.
Comment 7 Alex Pakhotin (:alexp) 2011-06-16 18:12:37 PDT
(In reply to comment #6)
> ::: configure.in
...
> > -        MOZ_THEME_FASTSTRIPE=1
> 
> I don't think this change is needed, can you confirm and remove? or explain
> why its required.

I've double-checked that (actually triple-checked :)). It seems like it is not actually required. I tried different things, and was consistently getting the issues with this flag enabled. Apparently it was affected by something else. For some reason the changes in the module code and makefiles are not always picked up by the build, I had to remove the binary files manually to build properly.
Anyway, I'm submitting a patch without this change.
Comment 8 Alex Pakhotin (:alexp) 2011-06-16 18:13:36 PDT
Created attachment 539961 [details] [diff] [review]
Fix v2

Updated patch.
r=blassey
Comment 10 Aaron Train [:aaronmt] 2011-07-26 08:38:06 PDT
Verified Fixed

Nightly:
Mozilla/5.0 (Android; Linux armv7l; rv:8.0a1) Gecko/20110726 Firefox/8.0a1 Fennec/8.0a1

Aurora:
Mozila/5.0 (Android; Linux armv7l; rv:7.0a2) Gecko/20110726 Firefox/7.0a2 Fennec/7.0a2
Comment 11 Tony Chung [:tchung] 2011-08-11 14:14:09 PDT
do we have tests for this?

Note You need to log in before you can comment on or make changes to this bug.