exception printed to console if --disable-gconf && browser.dom.window.dump.enabled

RESOLVED DUPLICATE of bug 729363

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 729363
7 years ago
6 years ago

People

(Reporter: Stefan, Unassigned)

Tracking

5 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.2a1pre) Gecko/20110409 Firefox/4.2a1pre

If FF has been configured with --disable-gconf and the preference browser.dom.window.dump.enabled is set to true an exeception is thrown, caught and written to console. Happens on start and on right click.

Reproducible: Always

Steps to Reproduce:
1. compile FF with --disable-gconf
2. set browser.dom.window.dump.enabled=true
3. start FF on command line
4. right-click into (empty) tab content area
Actual Results:  
after step 3. & 4. console reports:

*** e = [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://browser/content/utilityOverlay.js :: getShellService :: line 339"  data: no]

Expected Results:  
Don't throw.
(Reporter)

Comment 1

7 years ago
--disable-gconf has been introduced with Bug 645793

Updated

7 years ago
Version: unspecified → 5 Branch
(Reporter)

Updated

7 years ago
Depends on: 645793
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 729363
You need to log in before you can comment on or make changes to this bug.