Closed Bug 649804 Opened 9 years ago Closed 9 years ago

[xp debug][permaorange] Assertion failure: !rt->gcRunning, at e:/builds/moz2_slave/cen-w32-dbg/build/js/src/jscntxt.cpp:1019

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 629610

People

(Reporter: armenzg, Unassigned)

Details

Attachments

(1 file)

I am trying to add mochitest-browser-chrome back into the XP debug unit tests in bug 641059.

To do so I need this permaorange in js/src/jscntxt.cpp to be fixed.[1]

Can anyone have a look on this crash?

[1] http://hg.mozilla.org/mozilla-central/annotate/a6467a88b056/js/src/jscntxt.cpp#l1019
Do you actually mean literally permaorange, as in every single run without exception this happens?

It's a tiresome intermittent orange, one of only two where it happens in so many different tests that I've had to clone the bug to get room for more test names in the summary so it's bug 629610 *and* bug 648817, but when last they were running, it wasn't permaorange, just tiresomely frequent, as it is tiresomely frequent on every platform, thus the 450 failures just since the end of January.
I have setup the slave to continually run this so I can verify this.
You are right.
This is not a perma-orange. I got a green run yesterday.
I will run it a little longer and see how often it goes orange.

On the light of it, do you think we are ready to enable mochitest-browser-chrome for debug jobs for XP?
Yes. Based on my memory of the last time they were running, the permahang was the only thing stopping us from having them run.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 629610
We now have the twisted patch in place so it does not hang anymore the slaves.
No longer blocks: 641059
You need to log in before you can comment on or make changes to this bug.