merge aurora backouts into l10n-central

RESOLVED FIXED

Status

Core Graveyard
Tracking
RESOLVED FIXED
6 years ago
a year ago

People

(Reporter: Pike, Assigned: Pike)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(firefox6+ fixed)

Details

(Assignee)

Description

6 years ago
There are some 13(?) repositories for which gandalf did backouts of patches that do strings for central that are not supposed to be in the aurora cycle of April 12.

Leaving those backouts will cause trouble in the central-aurora merge for May 17, as backouts stay in merges.

There are three paths to fix:
- merge cleverly in May 17. High risk, as we can simply forget by then.
- redo the affected repos, not including the post-aurora-drop changesets nor their backouts. Logically the cleanest, but a tug-of-war between all parties, that's just gonna drag on. Also it blocks kicking up the l10n-dashboard until it's done.
- merge the backouts from aurora to l10n-central and back them out there, and merge today. Hacky, but makes hg do the right thing by default in May.

I can do #3, so I'll do it.

Let's gather a list, and then I'll file individual bugs per locale to communicate with the affected l10n teams.
(Assignee)

Comment 1

6 years ago
l10n/mozilla-aurora was set up in bug 649524, make that a dependency for regression linkage.
Depends on: 649524
Here comes the list of locales I identified as potential backouts:
ast	cs	de	es-AR	es-CL	es-ES	fr	it	nl	pl	pt-PT	ru	sv-SE

Notice, that not all of them have been affected because in two or three cases the backouts were not needed. You can identify that by checking the last commits.
(Assignee)

Comment 3

6 years ago
I see pushes by you to

ast cs cs de es-AR es-ES fr pl ru sv-SE

which is a nice little subset, and sums to 10. That sounds about right?
(Assignee)

Comment 4

6 years ago
Actually, 9, leaves es-CL it nl pt-PT to verify.
(Assignee)

Comment 5

6 years ago
Verified the 4, those should be good. Filing bugs for the other nine now.
(Assignee)

Updated

6 years ago
Depends on: 650251
(Assignee)

Updated

6 years ago
Depends on: 650253
(Assignee)

Updated

6 years ago
Depends on: 650255
(Assignee)

Updated

6 years ago
Depends on: 650257
(Assignee)

Updated

6 years ago
Depends on: 650259
(Assignee)

Updated

6 years ago
Depends on: 650260
(Assignee)

Updated

6 years ago
Depends on: 650261
(Assignee)

Updated

6 years ago
Depends on: 650262
(Assignee)

Updated

6 years ago
Depends on: 650264

Updated

6 years ago
tracking-firefox6: --- → ?

Comment 6

6 years ago
Axel, is there anything else remaining to do or have we verified we are ok after the migration today?
tracking-firefox6: ? → +
(In reply to comment #0)
> Leaving those backouts will cause trouble in the central-aurora merge for
> May 17, as backouts stay in merges.

since what we did today wasn't a merge, sounds like we ought to be ok
(Assignee)

Comment 8

6 years ago
The individual repos for es-ES and es-AR are still waiting to get their merges done by the localizers, and they might need to apply what the bugs describe to do so successfully.

So yes, there's remaining work to be done on two of the nine localizations, but not necessarily by us.

Comment 9

6 years ago
Axel, please resolve is all work here is done. Thanks.
Assignee: nobody → l10n
(Assignee)

Comment 10

6 years ago
Thanks for the poke.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
status-firefox6: --- → fixed
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.