Last Comment Bug 650244 - Error in test_tmpl_storage_bad_parameters_*.xul or test_tmpl_storage_badquery.xul or test_tmpl_storage_baddatasource.xul or test_tmpl_invalidqp.xul | got "[ Places Maintenance ]\n> Integrity check\n+ The database is sane\n> Coherence check\n+ ..."
: Error in test_tmpl_storage_bad_parameters_*.xul or test_tmpl_storage_badquery...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla7
Assigned To: :Gavin Sharp [email: gavin@gavinsharp.com]
:
Mentors:
: 655392 658761 (view as bug list)
Depends on: 751813
Blocks: 438871
  Show dependency treegraph
 
Reported: 2011-04-15 06:05 PDT by Rob Campbell [:rc] (:robcee)
Modified: 2012-11-25 19:31 PST (History)
8 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix the tests (2.13 KB, patch)
2011-05-26 10:56 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
ehsan: review+
enndeakin: feedback-
Details | Diff | Review

Description Rob Campbell [:rc] (:robcee) 2011-04-15 06:05:13 PDT
From the log:

822 INFO TEST-PASS | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_bad_parameters_3.xul | storage listbox with bad query parameters
NEXT ERROR 823 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_bad_parameters_3.xul | correct number of logged messages - got 2, expected 1
824 INFO TEST-PASS | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_bad_parameters_3.xul | logged message 1 - "Error parsing template: a query parameter cannot be bound to the SQL query" should equal "Error parsing template: a query parameter cannot be bound to the SQL query"
825 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_bad_parameters_3.xul | logged message 2 - got "[ Places Maintenance ]\n> Integrity check\n+ The database is sane\n> Coherence check\n+ The database is coherent", expected undefined
826 INFO TEST-END | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_bad_parameters_3.xul | finished in 768ms
827 INFO TEST-START | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_baddatasource.xul
WARNING: NS_ENSURE_TRUE(sf) failed: file ../../../docshell/base/nsDocShell.cpp, line 4970
WARNING: NS_ENSURE_TRUE(sf) failed: file ../../../docshell/base/nsDocShell.cpp, line 4970
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file ../../../../content/base/src/nsContentUtils.cpp, line 2917

As seen here:

http://tinderbox.mozilla.org/showlog.cgi?log=Devtools/1302788703.1302792305.29464.gz#err0
Comment 1 Treeherder Robot 2011-04-18 15:16:09 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303160654.1303164092.32081.gz
Rev3 Fedora 12 mozilla-central debug test mochitest-other on 2011/04/18 14:04:14

s: talos-r3-fed-003
823 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_bad_parameters_3.xul | correct number of logged messages - got 2, expected 1
825 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_bad_parameters_3.xul | logged message 2 - got "[ Places Maintenance ]\n> Integrity check\n+ The database is sane\n> Coherence check\n+ The database is coherent", expected undefined
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 2 Treeherder Robot 2011-04-20 13:14:29 PDT
jfkthame%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1303324605.1303327771.32588.gz
Rev3 Fedora 12x64 mozilla-aurora debug test mochitest-other on 2011/04/20 11:36:45

s: talos-r3-fed64-035
816 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_bad_parameters_3.xul | correct number of logged messages - got 2, expected 1
818 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_bad_parameters_3.xul | logged message 2 - got "[ Places Maintenance ]\n> Integrity check\n+ The database is sane\n> Coherence check\n+ The database is coherent", expected undefined
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 3 Treeherder Robot 2011-04-23 01:22:36 PDT
mh+mozilla%glandium.org
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1303542992.1303546437.15649.gz
Rev3 Fedora 12 mozilla-central debug test mochitest-other on 2011/04/23 00:16:32

s: talos-r3-fed-052
828 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_bad_parameters_3.xul | correct number of logged messages - got 2, expected 1
830 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_bad_parameters_3.xul | logged message 2 - got "[ Places Maintenance ]\n> Integrity check\n+ The database is sane\n> Coherence check\n+ The database is coherent", expected undefined
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 4 Joe Drew (not getting mail) 2011-05-17 09:26:03 PDT
*** Bug 655392 has been marked as a duplicate of this bug. ***
Comment 5 Joe Drew (not getting mail) 2011-05-17 09:30:02 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1305644257.1305648039.16707.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test 

s: talos-r3-snow-052
912 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_badquery.xul | correct number of logged messages - got 2, expected 1
914 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_badquery.xul | logged message 2 - got "[ Places Maintenance ]\n> Integrity check\n+ The database is sane\n> Coherence check\n+ The database is coherent", expected undefined
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 6 Treeherder Robot 2011-05-17 22:42:00 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1305692094.1305695879.27201.gz
Rev3 MacOSX Snow Leopard 10.6.2 tracemonkey debug test mochitest-other on 2011/05/17 21:14:54

s: talos-r3-snow-004
899 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_bad_parameters_3.xul | correct number of logged messages - got 2, expected 1
901 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_bad_parameters_3.xul | logged message 2 - got "[ Places Maintenance ]\n> Integrity check\n+ The database is sane\n> Coherence check\n+ The database is coherent", expected undefined
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 7 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-23 15:13:04 PDT
These tests are too fragile. Places just happens to be doing it's cleanup while they're running, and they can't tolerate someone else spamming the console. The tests should not assume that they have the console to themselves.
Comment 8 Treeherder Robot 2011-05-24 01:22:10 PDT
bmcbride%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1306220457.1306224429.21669.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2011/05/24 00:00:57

s: talos-r3-snow-016
907 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_baddatasource.xul | correct number of logged messages - got 2, expected 1
909 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_baddatasource.xul | logged message 2 - got "[ Places Maintenance ]\n> Integrity check\n+ The database is sane\n> Coherence check\n+ The database is coherent", expected undefined
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
Comment 9 Treeherder Robot 2011-05-24 21:35:02 PDT
dbaron
http://tinderbox.mozilla.org/showlog.cgi?log=Try/1306293094.1306296939.982.gz
Rev3 Fedora 12 try debug test mochitest-other on 2011/05/24 20:11:34

s: talos-r3-fed-005
911 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_badquery.xul | correct number of logged messages - got 2, expected 1
913 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/content/xul/templates/tests/chrome/test_tmpl_storage_badquery.xul | logged message 2 - got "[ Places Maintenance ]\n> Integrity check\n+ The database is sane\n> Coherence check\n+ The database is coherent", expected undefined
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_bug577990.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_bug577990.js | Found unexpected add-ons manager window still open
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_bug577990.js | Should not get category when manager window is not loaded - Didn't expect null, but got it
Comment 10 Phil Ringnalda (:philor) 2011-05-25 21:03:10 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Private-Browsing/1306364245.1306368185.26500.gz

Please disable your tests until they get unbroken.
Comment 11 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-26 10:56:22 PDT
Created attachment 535408 [details] [diff] [review]
fix the tests

I verified that the tests still fail if the error reporting is disabled (made nsXULContentUtils::LogTemplateError a noop).
Comment 12 :Ehsan Akhgari (busy, don't ask for review please) 2011-05-26 13:43:14 PDT
http://hg.mozilla.org/projects/cedar/rev/d998c37534b1
Comment 13 Neil Deakin 2011-05-26 14:00:18 PDT
Comment on attachment 535408 [details] [diff] [review]
fix the tests

Looks wrong to me. This will ignore all extra errors even when those extra errors are template related, no?

Is there a bug on removing the places junk being output?
Comment 14 Neil Deakin 2011-05-26 14:25:33 PDT
*** Bug 658761 has been marked as a duplicate of this bug. ***
Comment 15 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-26 15:49:37 PDT
(In reply to comment #13)
> Looks wrong to me. This will ignore all extra errors even when those extra
> errors are template related, no?

Yes. Is it important to test that no additional template errors were produced? That seems unlikely to happen (and a minor bug if it somehow does).

I suppose you could add an else branch that checks is(messages[m].indexOf("Error parsing template"), -1, "additional message should not be a template message") or something (assuming all of these really do go through nsXULContentUtils::LogTemplateError).
Comment 16 Mounir Lamouri (:mounir) 2011-05-27 01:07:02 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/d998c37534b1
Comment 17 :Ehsan Akhgari (busy, don't ask for review please) 2011-05-30 08:26:06 PDT
Reopening for Neil's comments to be addressed.
Comment 18 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-06-09 21:57:13 PDT
I don't think that's needed, but if so it can happen in another bug.

Note You need to log in before you can comment on or make changes to this bug.