Closed Bug 650291 Opened 9 years ago Closed 9 years ago

If MU builder is not clobbered we should stop earlier

Categories

(Release Engineering :: General, defect, major)

x86
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 590329

People

(Reporter: armenzg, Unassigned)

References

Details

In bug 650268 /builds/slave/rel-192-mu/build/mozilla was not clobbered and that caused the job to stop.

Any successive job I triggered would fail at "commit_verify_configs" because that step was executed on the first job and there is nothing that can be committed since there are no changes.

If the MU job had stopped before committing anything I would have been able to trigger it again in another slave.

The workaround until clobberer gets fixed is to run manually the steps.
I worked around this by backing out the update verify commit to the tools repo from the first job:
http://hg.mozilla.org/build/tools/rev/cd5728db1b57
backed out by:
http://hg.mozilla.org/build/tools/rev/015583a6b6fe

On another note, would it make sense to adjust the commit message to indicate the "from" version?
This:
"Automated configuration bump: update verify configs from 3.6.17 build 2 to 4.0.1 build 1 "
instead of:
"Automated configuration bump: update verify configs for 4.0.1 build 1 "
This is a general release builder problem
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 590329
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.