Last Comment Bug 650602 - Intermittent failure in content/html/content/reftests/583514-1.html and content/html/content/reftests/583514-2.html
: Intermittent failure in content/html/content/reftests/583514-1.html and conte...
Status: RESOLVED FIXED
[fixed by bug 650629]
: intermittent-failure
Product: Core
Classification: Components
Component: Layout: Form Controls (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on: 650629
Blocks: 438871
  Show dependency treegraph
 
Reported: 2011-04-16 23:35 PDT by Phil Ringnalda (:philor)
Modified: 2012-11-25 19:31 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
reftest log (23.35 KB, text/plain)
2011-04-16 23:35 PDT, Phil Ringnalda (:philor)
no flags Details

Description Phil Ringnalda (:philor) 2011-04-16 23:35:49 PDT
Created attachment 526569 [details]
reftest log

The difference is that the test lacks the text "input focused" which sort of surprises me, since I'd think if Fennec fails to fire onfocus it would be failing more than just one reftest from it.
Comment 1 Mounir Lamouri (:mounir) 2011-04-17 05:33:57 PDT
That's exactly the kind of tests that should not go into the tree :( It's completely wrong...
Comment 2 Mounir Lamouri (:mounir) 2011-04-17 05:37:25 PDT
BTW, this has nothing to do with Android. It just happens to fail on Android but that's an intermittent failure.
Comment 3 Phil Ringnalda (:philor) 2011-04-17 09:53:17 PDT
I don't think it's intermittent, unless the intermittency period is "only fails 20 out of 21 runs" since I looked at 20. Annotated as failing on Android in http://hg.mozilla.org/mozilla-central/rev/af907a37dcf0, if I have to eat my words and change the fails-if, well, won't be the first time.
Comment 4 Mounir Lamouri (:mounir) 2011-04-17 10:00:15 PDT
(In reply to comment #3)
> I don't think it's intermittent, unless the intermittency period is "only fails
> 20 out of 21 runs" since I looked at 20. Annotated as failing on Android in
> http://hg.mozilla.org/mozilla-central/rev/af907a37dcf0, if I have to eat my
> words and change the fails-if, well, won't be the first time.

I think it's intermittent but it may fails 100% of the time on Android for other reasons. What I mean is that might fail as well on other platforms the same way I got it failing on mine.
Comment 5 Mounir Lamouri (:mounir) 2011-04-18 04:52:31 PDT
Bug 650629 removed these tests (in favor of mochitests) so I guess we can consider that bug fixed.

Note You need to log in before you can comment on or make changes to this bug.