[autoconfig] Can't create accounts - fails at around the time of searching the ISP database (getService fails in guessConfig.js)

RESOLVED FIXED in Thunderbird 5.0b1

Status

Thunderbird
Account Manager
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

({regression})

Trunk
Thunderbird 5.0b1
regression

Firefox Tracking Flags

(blocking-thunderbird5.0 beta1+)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Created attachment 526789 [details] [diff] [review]
The fix

I was trying out the new account wizard on my debug build on a fresh profile, and when the dialog got displayed, I saw the following:

###!!! ASSERTION: Recursive GetService!: 'Error', file /Users/moztest/comm/aurora/src/mozilla/xpcom/components/nsComponentManager.cpp, line 1663
JavaScript error: , line 0: uncaught exception: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://messenger/content/accountcreation/guessConfig.js :: <TOP_LEVEL> :: line 41"  data: no]

I then tried to do some lookups, and Thunderbird crashed part way through.

This appears to be fallout from bug 619201, which now makes NSS initialise the certificate override service (nsICertOverrideService).

guessConfig.js tries to fill a global variable with the service when we open up the account wizard. The issue here is that it then causes NSS to initialise, which then means NSS tries to getService the nsICertOverrideService, at which point XPCOM complains.

I think the easiest way around this for us is to not have the global variable, but just use the service when we actually require it.
Attachment #526789 - Flags: review?(bwinton)

Comment 1

7 years ago
I had the same issue with a new mozilla-aurora based TB build (Windows 7 64 bit). In addition, my Exchange Server calls after the account wizard that used https: were also failing. Applying the patch fixed my issues.
Comment on attachment 526789 [details] [diff] [review]
The fix

Review of attachment 526789 [details] [diff] [review]:

Yeah, this looks like it fixes the bug.  r=me.

Thanks,
Blake.
Attachment #526789 - Flags: review?(bwinton) → review+
(Assignee)

Comment 3

7 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/31ad9acf5213
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a4
You need to log in before you can comment on or make changes to this bug.