Closed Bug 651101 Opened 9 years ago Closed 9 years ago

Loading the given web page acquires 500MB memory which mostly never gets freed after closing the tab

Categories

(Core :: JavaScript Engine, defect, major)

All
macOS
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: whimboo, Unassigned)

References

()

Details

(Keywords: memory-leak, Whiteboard: [mozmill-test-needed][mozmill-endurance])

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a1) Gecko/20110413 Firefox/6.0a1

Loading the web page given in the URL field will take up to 500 MB of memory usage on my OS X box after a couple of minutes. Not sure if this is related to the never ending loading status. But closing the tab never frees the memory so the usage drops back to the amount of used memory before the page has been loaded. Because of a crash on older branches I cannot try to reproduce it there. See bug 650874.
Whiteboard: [mozmill-test-needed][mozmill-endurance]
Henrik, how are you measuring usage?  RSIZE from 'top' or RSS from 'ps'?  Something else?
The bogus code which caused this high mem usage and the crash on the older branches has been removed from this site. Now it's no longer reproducible and I also don't have a local copy of the page. :/ Closing as WFM.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
No longer blocks: mlk-fx5+
You need to log in before you can comment on or make changes to this bug.