Closed Bug 651114 Opened 13 years ago Closed 13 years ago

Clean up browser_tabview_bug612470.js

Categories

(Firefox Graveyard :: Panorama, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 6

People

(Reporter: ttaubert, Assigned: ttaubert)

Details

Attachments

(1 file, 1 obsolete file)

The test times out in single mode and we could use some of the new head.js functions.
Attached patch patch v1 (obsolete) — Splinter Review
Attachment #526971 - Flags: feedback?(raymond)
Attachment #526971 - Flags: feedback?(raymond) → feedback+
Attachment #526971 - Flags: review?(ian)
Comment on attachment 526971 [details] [diff] [review]
patch v1

> /* Any copyright is dedicated to the Public Domain.
>    http://creativecommons.org/publicdomain/zero/1.0/ */
> 
> // Tests that groups behave properly when closing all tabs but app tabs.

I really like that there's a comment at the top here describing what the test is for... might be a good habit to get into.

>+  newWindowWithTabView(function (tvwin) {
>+    registerCleanupFunction(function () tvwin.close());
> 
>-  addEventListener("tabviewshown", createGroup, false);
>-  TabView.toggle();
>+    win = tvwin;
>+    cw = win.TabView.getContentWindow();
>+    executeSoon(function () onShow());
>+  }, onLoad);

I found it a little confusing that of the two functions passed into newWindowWithTabView, one was defined right here and the other was defined above and passed only by name. I think passing them both by name would be clearer (otherwise it's easier to forget which function is for what), though I suppose a middle ground would be to name the functions inline: 

newWindowWithTabView(function onShow (tvwin) {
  ...
}, function onLoad () {
  ...
});

Anyway, food for thought.
Attachment #526971 - Flags: review?(ian) → review+
(In reply to comment #3)
> I really like that there's a comment at the top here describing what the test
> is for... might be a good habit to get into.

True. Noted :)

> I found it a little confusing that of the two functions passed into
> newWindowWithTabView, one was defined right here and the other was defined
> above and passed only by name. I think passing them both by name would be
> clearer (otherwise it's easier to forget which function is for what)

Fixed.
Attachment #526971 - Attachment is obsolete: true
Keywords: checkin-needed
In my queue.
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/7b7a77e74c78
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 6
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: