Last Comment Bug 651229 - nsLineBox.cpp:663: warning: unused variable 'presContext'
: nsLineBox.cpp:663: warning: unused variable 'presContext'
Status: RESOLVED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: Layout: Text (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Daniel Holbert [:dholbert]
:
Mentors:
http://tinderbox.mozilla.org/showlog....
Depends on:
Blocks: 624798
  Show dependency treegraph
 
Reported: 2011-04-19 13:49 PDT by Daniel Holbert [:dholbert]
Modified: 2011-04-21 10:23 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (830 bytes, patch)
2011-04-19 13:49 PDT, Daniel Holbert [:dholbert]
smontagu: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2011-04-19 13:49:11 PDT
Created attachment 527088 [details] [diff] [review]
fix

Filing bug on this newish build warning:
> layout/generic/nsLineBox.cpp: In member function 'virtual nsresult nsLineIterator::CheckLineOrder(PRInt32, PRBool*, nsIFrame**, nsIFrame**)':
> layout/generic/nsLineBox.cpp:663: warning: unused variable 'presContext'

Looks like the last use of this variable was removed in bug 624798:
>    nsPresContext* presContext = line->mFirstChild->PresContext();
>  
> -  nsBidiPresUtils* bidiUtils = presContext->GetBidiUtils();
> -

Fix attached.
Comment 1 Daniel Holbert [:dholbert] 2011-04-21 10:23:07 PDT
pushed: http://hg.mozilla.org/mozilla-central/rev/7ad20fbb9992

Note You need to log in before you can comment on or make changes to this bug.