Jumpy/slow scrolling on second screen when docked with Lenovo T410

RESOLVED DUPLICATE of bug 633904

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 633904
7 years ago
2 years ago

People

(Reporter: Paul Sanders, Unassigned)

Tracking

({perf})

2.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

I have a Lenovo T410. With it docked I have the laptop screen as my main screen and the screen extended to a second monitor. When Firefox is on the second monitor the scrolling becomes jerkey and slow. If I move Firefox to the laptop window the problem isn't there. I have tried other programs (Chrome, IE etc.) and none of them have this problem. I have just moved to the Lenovo and was using a Dell Latitude before with the same setup but no problem with the screen so it seems to be specific to the Lenovo. The problem is present both with smooth scrolling turned on and off.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox
2. Put Firefox on the "extended desktop"
3. Scroll on the page
Actual Results:  
Jerkey slow scrolling

Expected Results:  
No delay in the scrolling

Comment 1

7 years ago
I am having the same issue with the same setup.  It only occurs on the secondary extended monitor, not the primary T410 monitor.  Additionally I experience a brief pause with the mouse when a piece of JavaScript runs (i.e. mouse overs and mouse outs).
Is the Issue reproducible in Safe-Mode for you guys?
https://support.mozilla.com/en-US/kb/Safe+Mode
Version: unspecified → 4.0 Branch

Comment 3

7 years ago
Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110420 Firefox/6.0a1

Please try a clean profile also:
http://support.mozilla.com/en-US/kb/Managing%20profiles

Could it be related to hardware acceleration? Try disabling it and see whether you can still reproduce the issue.
(Reporter)

Comment 4

7 years ago
The problem is not there in Safe-Mode. I haven't installed any extensions yet so that isn't the problem. I tried to go through and disable plugins (flash, etc) one by one but the problem was still there with everything disabled when not in Safe-Mode.
(Reporter)

Comment 5

7 years ago
I tried a clean profile and turning off hardware acceleration but neither made any difference.
OS: Windows XP → All
(In reply to comment #5)
> I tried a clean profile and turning off hardware acceleration but neither
> made any difference.

Did you restart Firefox when disabling Hardware Accel.?
(Reporter)

Comment 7

7 years ago
(In reply to comment #6)
> (In reply to comment #5)
> > I tried a clean profile and turning off hardware acceleration but neither
> > made any difference.
> 
> Did you restart Firefox when disabling Hardware Accel.?

I thought I had, but apparently not. I just tried again and turning off hardware acceleration stopped the problem.
Ok, thanks. Looks like another "docked Monitor + HWA Usage" Issue.

Paul, please post the Content of the Graphics Section you can get via "about:support" after you re-enabled Hardware Acceleration.
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Version: 4.0 Branch → 2.0 Branch
(Reporter)

Comment 9

7 years ago
Here is the graphics info.

Adapter Description: Intel(R) HD Graphics
Vendor ID: 8086
Device ID: 0046
Adapter RAM: Unknown
Adapter Drivers: igxprd32
Driver Version: 6.14.10.5292
Driver Date: 8-13-2010
Direct2D Enabled: false
DirectWrite Enabled: false (0.0.0.0, font cache n/a)
WebGL Renderer:Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.611)
GPU Accelerated Windows: 1/1 Direct3D 9

Comment 10

6 years ago
I think this is a duplicate of Bug 633904 (or vice versa). Same behavior, graphics adapter, OS, and similar driver versions.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Depends on: 633904
Keywords: perf
Resolution: --- → DUPLICATE
Duplicate of bug: 633904
You need to log in before you can comment on or make changes to this bug.