Closed Bug 651593 Opened 11 years ago Closed 11 years ago

[WT] Automatically track off-site links

Categories

(www.mozilla.org :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: lforrest, Assigned: lforrest)

References

Details

Attachments

(3 files)

Hey Brad - 

We'd love a way to automatically track all our offsite links. As you know, our Mozilla Web Universe is vast, and we have a lot of links connecting people to other sites that are contained within other profiles. 

It would be great to have a way to automatically see all the CTR data from each link, without having to provide custom tagging each time. You mentioned this is a setting within the WT tag builder (or something along those lines). Let's implement that. 

Example:
Be able to see how many people are clicking, and what the CTR is from http://www.mozilla.com/en-US/firefox/fx/ to the Spark micro-site, and the Web o Wonder.

Note: With Wes we did implement some WT.ad tags, but a complimentary report was never created since our engagement ended. Also, I'm not sure those will provide what we're looking for in the case of this bug. Just thought I'd note it here - we can review more in person.
We talked about this last Wednesday and the issue of sampling came up. Since the Mozilla.com profile samples at 50%, it's fine if this report does so as well. Basically, whatever the profile samples at, it's corresponding offsite link report can use that sampling too. 

Bard - knowing that, can you advise on next steps?
I will need to update your core JavaScript tag.  I should have that done EOD Tuesday.
(In reply to comment #2)
> I will need to update your core JavaScript tag.  I should have that done EOD
> Tuesday.

Great. When you're done, please attach new JavaScript tag and implementation instructions here. Thanks.
This is related to bug 646992.  Due to the fact that this will require an update to the core Webtrends data collection JavaScript, it will require careful testing prior to implementation.  This should be completed by Wednesday of next week.
I've updated the core JavaScript to implement automatic link tracking.  This code will automatically track all link clicks, both on and off site.  This can be updated to track offsite only if need be.
Sounds good. Let's try this out on a test site first, and be sure to exclude a link click from a "page view." Let's see how much this change increases our monthly calls to WT, and if the benefit is worth the increase in server calls. 

Please attach that code here with implementation instructions.
Please rename the javascript file as you see fit.  I basically added link tracking functionality to your already existing core script.
David - Attached is a modification to the webtrends code that will automatically track all links (including offsite links). Do you mind implementing it on Mozilla.org? We'd like to test it for a while to see if we should eventually apply to Mozilla.com. 

We discussed with our technical contact at WT, Brad, and he suggested testing in order to see: 1. How useful automatically having offsite link info will be 2. Monitoring how this increases our server hits to WT, since this code essentially tracks every click on the site, thus increasing hits we send to WT. 

David - how does this sound?

Brad - anything to add?
Assignee: brad.gross → dboswell
Laura, sure, I'm happy to give this a try on mozilla.org to test.  I probably won't have time to look at it this week though.
(In reply to comment #10)
> Laura, sure, I'm happy to give this a try on mozilla.org to test.  I
> probably won't have time to look at it this week though.

Thanks! That's fine. Perhaps next week?
Laura, hopefully I'll have time next week after the work week is over.

One other thought is that we could ask James or Anthony to take a look so that they can get familiar with mozilla.org code in general and the WebTrends setup on mozilla.org in particular.  Not sure if they'll have any more availability though.
Hey David - Is this a possibility to deploy this week? If not, I'll inquire with James.
Apologies for taking a while to look at this.

If I understand this correctly based on comment #7, I just need to replace the old webtrends.js file with the attached js file.

I just checked this in on stage in r89736 just to make sure this doesn't hork the site, although this won't tell us if it's working on Webtrends' side.

I'll move over to production if stage seems to stay happy after 30 minutes or so.
Stage still seems to be with us, so I checked this in to the live site in r89739.

I don't know exactly what to look for in Webtrends to determine if this is working as intended so please let me know if cool new reports start showing up :)
Once the new javascript has been installed link clicks should start automatically being sent to SDC log files (note:  these clicks will still be subject to the same sampling code as page loads).  

In order to confirm this, we can create a custom report that specifically looks for link clicks OR the log files can be examined directly.
Blocks: 662671
Thanks David! For snazzy reports follow Bug 662671. 

Closing this implementation bug.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Re-opening since Brad is suggesting we revert back to the old code. 

David - Can you please revert back? 

Brad - why the switch back? Is data properly flowing since we implemented the new JS? Is that data reliable?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Since the release of the new JS, the mozilla.org site is no longer sending hits to the Webtrends SDC server.  I believe I know what the issue is but need to double check it on my end.
Webtrends.js file reverted in r90131.

Brad, please confirm as soon as possible that this is working correctly.
Confirmed, Mozilla.org is now sending hits to our SDC server again.

Thanks for the quick turn-around time.
For next steps Brad will provide new JS code that will work on Mozilla.org. 

The corrections he makes will not lead us into the problem we just experienced.
Here is an updated copy of the Webtrends core data collection JavaScript that has been customized to enable link tracking.  It has also been tailored to work specifically with the www.mozilla.org domain.
I attached a new data collection JavaScript file.  Please verify that hits are being sent to our SDC server from the staging environment.
I added the new js file to the site in r90439 to www.mozilla.org.  Let me know if this is working or if we should revert to the earlier version.
It looks like we're getting both page load and click tracking hits.  I will take a closer look tomorrow (I'm OOO today)
Next step here is to set up the link tracking report. Brad - have at it.
Assignee: dboswell → brad.gross
I added several link tracking reports to the Mozilla.org profile.  Please have a look.
Assignee: brad.gross → lforrest
They look great. Closing this bug since this work is now done. See bug 666319 for more details.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Depends on: 666319
Resolution: --- → FIXED
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.