Last Comment Bug 651657 - Remove WinCE & Windows Mobile code from dom/*
: Remove WinCE & Windows Mobile code from dom/*
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All Windows CE
: -- normal (vote)
: mozilla6
Assigned To: Ed Morley [:emorley]
:
:
Mentors:
Depends on:
Blocks: 614720
  Show dependency treegraph
 
Reported: 2011-04-20 15:29 PDT by Ed Morley [:emorley]
Modified: 2011-07-29 07:09 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove WinCE & Windows Mobile code from dom/* (12.50 KB, patch)
2011-04-20 16:41 PDT, Ed Morley [:emorley]
jst: review+
dolske: review+
Details | Diff | Splinter Review
Remove WinCE & Windows Mobile code from dom/* (12.51 KB, patch)
2011-04-28 15:35 PDT, Ed Morley [:emorley]
emorley: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-04-20 15:29:28 PDT
WinCE & Windows Mobile code is being slowly removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the dom/* parts of the removal.
Comment 1 Ed Morley [:emorley] 2011-04-20 16:41:15 PDT
Created attachment 527422 [details] [diff] [review]
Remove WinCE & Windows Mobile code from dom/*

Remove WinCE & Windows Mobile ifdefs from dom/*
+ hg rm WinMobileLocationProvider.(h|cpp)

Justin hope you don't mind another r? ; this is much smaller than the patch in the other bug at least! :-)
Comment 2 Ed Morley [:emorley] 2011-04-23 10:17:54 PDT
Passed try (after repeating a few of the tests for intermittent oranges):
http://dev.philringnalda.com/tbpl/?tree=Try&rev=cca063ae0577
Comment 3 Justin Dolske [:Dolske] 2011-04-26 17:59:44 PDT
Comment on attachment 527422 [details] [diff] [review]
Remove WinCE & Windows Mobile code from dom/*

Bouncing over to jst, looks fine to me though.
Comment 4 Johnny Stenback (:jst, jst@mozilla.com) 2011-04-28 14:20:26 PDT
Comment on attachment 527422 [details] [diff] [review]
Remove WinCE & Windows Mobile code from dom/*

Review of attachment 527422 [details] [diff] [review]:

r=jst
Comment 5 Ed Morley [:emorley] 2011-04-28 15:35:32 PDT
Created attachment 528969 [details] [diff] [review]
Remove WinCE & Windows Mobile code from dom/*

Only change is updated commit message to include the r=jst,dolske.

Carrying forwards r+
Comment 6 Dão Gottwald [:dao] 2011-04-29 06:53:36 PDT
http://hg.mozilla.org/mozilla-central/rev/c39785cf8fb8
Comment 7 AndreiD[QA] 2011-07-29 07:09:24 PDT
Build: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0
The changes made in m-c and landed (comment 6) are visible in hg, under beta (i.e. the file WinMobileLocationProvider.cpp is not available anymore).
Setting this as verified for Firefox 6 Beta

Note You need to log in before you can comment on or make changes to this bug.