When switching channels, I get a failed update

VERIFIED FIXED in Firefox 5

Status

()

Toolkit
Application Update
--
major
VERIFIED FIXED
7 years ago
5 years ago

People

(Reporter: christian, Assigned: rstrong)

Tracking

Trunk
mozilla5
Points:
---
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(firefox5- fixed)

Details

(Whiteboard: [channel-switcher])

Attachments

(7 attachments, 3 obsolete attachments)

(Reporter)

Description

7 years ago
Created attachment 527687 [details]
Screenshot 1

1. Check the about dialog on an older build on the aurora channel
2. Make sure there is an update already downloaded and ready to install (the button says "Apply Update")
3. Change to the "Beta" channel
4. Click "Apply and Update"
5. Notice an update downloads, even though one was 100% downloaded previously
6. Get an "Update failed" message
(Reporter)

Comment 1

7 years ago
Created attachment 527689 [details]
Screenshot 2
(Reporter)

Comment 2

7 years ago
Created attachment 527690 [details]
Screenshot 3
(Reporter)

Comment 3

7 years ago
Created attachment 527691 [details]
Screenshot 4
limi, what UX behavior should we have? For example, if there is an update ready to apply should the user have the ability to change the channel?
(Reporter)

Comment 5

7 years ago
Created attachment 527693 [details]
Update log

Update log attached. I haven't tried to see if it works itself out yet.
No more files are needed... btw: the update.log is from the previously applied update and there is no log file for the failed download.
(Reporter)

Updated

7 years ago
Attachment #527693 - Attachment is obsolete: true
(In reply to comment #4)
> limi, what UX behavior should we have? For example, if there is an update ready
> to apply should the user have the ability to change the channel?

Yes, you should always be able to change the channel.

If there's an update queued for e.g. the Beta channel and you want to switch to the Aurora channel, we should discard the update and get the Aurora one instead.
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Whiteboard: [channel-switcher]
Duplicate of this bug: 655244

Updated

7 years ago
status-firefox5: --- → affected
tracking-firefox5: --- → ?
OS: Mac OS X → All

Comment 10

7 years ago
will look again at a patch approval request but not going to track this through this flag.
tracking-firefox5: ? → -

Comment 11

7 years ago
Hey Rob, is your intent to get this fixed for FF5?
I've got a patch but I've had trouble finishing up the tests and my eye problems flared up again... still hopeful to have it done today.
Created attachment 532716 [details] [diff] [review]
patch rev1

Dave, I'll followup with tests later after I get replacement eyeglasses
Attachment #528565 - Attachment is obsolete: true
Attachment #532716 - Flags: review?(dtownsend)
Created attachment 532863 [details] [diff] [review]
main patch rev1
Attachment #532716 - Attachment is obsolete: true
Attachment #532716 - Flags: review?(dtownsend)
Attachment #532863 - Flags: review?(dtownsend)
Created attachment 532895 [details] [diff] [review]
tests rev1
Attachment #532895 - Flags: review?(dtownsend)
Comment on attachment 532863 [details] [diff] [review]
main patch rev1

Review of attachment 532863 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/mozapps/update/nsUpdateService.js
@@ +500,5 @@
>    var channelChangeFile = dir.clone();
>    channelChangeFile.append(FILE_CHANNELCHANGE);
> +  if (!channelChangeFile.exists())
> +    channelChangeFile.create(Ci.nsILocalFile.NORMAL_FILE_TYPE,
> +                             FileUtils.PERMS_FILE);

nit: braces around this
Attachment #532863 - Flags: review?(dtownsend) → review+
Comment on attachment 532895 [details] [diff] [review]
tests rev1

Review of attachment 532895 [details] [diff] [review]:
-----------------------------------------------------------------
Attachment #532895 - Flags: review?(dtownsend) → review+
Comment on attachment 532863 [details] [diff] [review]
main patch rev1

Requesting approval for Aurora and Beta before landing on m-c since the code is only exercised on Aurora and Beta
Attachment #532863 - Flags: approval-mozilla-beta?
Attachment #532863 - Flags: approval-mozilla-aurora?
Missed this approval for aurora before the merge, but if you land it on central now, it'll get picked up in next week's aurora merge for FF6 and the world will be a happier place for Aurora users at least. We can take it on beta after that, or wait 6 weeks for it to get there on its own, based on the risk/reward calculus for those users.
Created attachment 533340 [details] [diff] [review]
main patch rev2 - updated to comments
Attachment #533340 - Flags: review+
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/195b5dc114c5
http://hg.mozilla.org/mozilla-central/rev/062dccbd5674
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → mozilla6
Attachment #532863 - Flags: approval-mozilla-beta?
Attachment #532863 - Flags: approval-mozilla-aurora?
Comment on attachment 533340 [details] [diff] [review]
main patch rev2 - updated to comments

Readding the beta approval request
Attachment #533340 - Flags: approval-mozilla-beta?
Attachment #533340 - Flags: approval-mozilla-aurora?

Updated

7 years ago
Attachment #533340 - Flags: approval-mozilla-beta?
Attachment #533340 - Flags: approval-mozilla-beta+
Attachment #533340 - Flags: approval-mozilla-aurora?

Comment 23

7 years ago
Comment on attachment 533340 [details] [diff] [review]
main patch rev2 - updated to comments

Please land this change on both Aurora and Beta. (In the future, getting changes in during Aurora will save you this extra step.)
Attachment #533340 - Flags: approval-mozilla-aurora+

Comment 25

7 years ago
Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0 - Firefox 5 Beta - build 3

Verified the issue on WinXP and it's no longer reproducible.
The update testing was done between Aurora 6.0a2 to Beta 5.0b3.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.