If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Create About:Home Snippet to push Aurora users to "fake" beta

RESOLVED FIXED

Status

www.mozilla.org
General
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: lmesa, Assigned: lorchard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
In order to test the channel switching mechanism, we need to create a snippet that asks users to use the channel switcher to move to Beta. 

The copy needs to say something like--"Help us test the Channel Switcher in Aurora. Go to About Aurora and change your channel to Beta. _Learn more._

We could use the lightbulb or the Aurora logo in the snippet as the visual. 

Learn more will then link to a SUMO article who's URL is yet TBD explaining the channel switcher process and why we're doing this.  

We'd like the snippet to be ready to go Thursday of next week, 4/28.
(Reporter)

Updated

7 years ago
Assignee: nobody → lforrest

Comment 1

7 years ago
Sounds good. Before that can happen I need the final copy (Cc-ed John and Matej here), and the final link. Assigning to you until those assets are finalized.
Assignee: lforrest → lmesa
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Sounds good. Before that can happen I need the final copy (Cc-ed John and Matej
> here),

Should I file a copy bug?

 and the final link. Assigning to you until those assets are finalized.

Comment 3

7 years ago
No need for a separate copy bug. I actually think your copy in comment #0 sounds good. Only concern is will they know how to go to About Aurora and find the channel switcher? That seems a bit vague, but of course we don't have much room to go into any real detail.

Would also be nice to explain why we're doing this, but again there's not much room. Why exactly are we asking them to do this? What's the benefit for us?

For now, a slight slight edit:

Help us test the Channel Switcher: go to About Aurora and change your channel to Beta. Thanks! _Learn more._

Comment 4

7 years ago
The SUMO article will explain what the channel switcher is and how to use it and what to expect.  Will that be enough?
(Reporter)

Comment 5

7 years ago
(In reply to comment #4)
> The SUMO article will explain what the channel switcher is and how to use it
> and what to expect.  Will that be enough?

I think it is. The blog post on FR should then answer any questions about how to get back.(In reply to comment #3)

> 
> For now, a slight slight edit:
> 
> Help us test the Channel Switcher: go to About Aurora and change your channel
> to Beta. Thanks! _Learn more._

Sounds great!

I'll go ahead and reassign to lforrest if all agree?

Comment 6

7 years ago
(In reply to comment #5)
> I'll go ahead and reassign to lforrest if all agree?

+1
(Reporter)

Updated

7 years ago
Assignee: lmesa → lforrest

Comment 7

7 years ago
Final Copy: Help us test the Channel Switcher: go to About Aurora and change your channel to Beta. Thanks! _Learn more._

Final Link: TBD coming from Laura M.

Les: To target the Aurora channel what would the "Product Version" be? I can create the new Client Match Rule.
(Assignee)

Comment 8

7 years ago
(In reply to comment #7)
> Final Copy: Help us test the Channel Switcher: go to About Aurora and change
> your channel to Beta. Thanks! _Learn more._
> 
> Final Link: TBD coming from Laura M.

Will this be localized? Again, as mentioned in bug 650894, we'll need something like bug 651868 to collect localized attachments for import into the service.

> Les: To target the Aurora channel what would the "Product Version" be? I can
> create the new Client Match Rule.

That depends: Do we really mean product version here (ie. 5.0) or do we mean the Aurora channel going forward?

If version, then "product version" can be "5.0"

If channel, then "distribution" should be "aurora" and "product version" left blank - at least if what was decided in bug 648001 is correct
(Reporter)

Comment 9

7 years ago
(In reply to comment #8)
> (In reply to comment #7)
> > Final Copy: Help us test the Channel Switcher: go to About Aurora and change
> > your channel to Beta. Thanks! _Learn more._
> > 
> > Final Link: TBD coming from Laura M.
> 
> Will this be localized? Again, as mentioned in bug 650894, we'll need something
> like bug 651868 to collect localized attachments for import into the service.
> 
No need to localize these guys. En-US only.
thanks everyone. 

les and lauraf,
we'd like the snippets to be live by Friday 4/29. From my understanding, we need to push it by tomorrow if we want them to be live by this friday? Please confirm once it's push to production and that snippets will be live by Friday 4/29. 
 
thanks!
take it back.. it needs to be push to production by Friday and live date by Monday, May 2nd. thanks.
(Assignee)

Comment 12

7 years ago
(In reply to comment #11)
> take it back.. it needs to be push to production by Friday and live date by
> Monday, May 2nd. thanks.

This snippet's copy is final - but still waiting on an image and a link, no? Can't move ahead without those.
(In reply to comment #12)
> (In reply to comment #11)
> > take it back.. it needs to be push to production by Friday and live date by
> > Monday, May 2nd. thanks.
> 
> This snippet's copy is final - but still waiting on an image and a link, no?
> Can't move ahead without those.

will try to see if i can get the beta logo and wordmark resize, since we are promoting the (fake) beta. if not, we can use the aurora logo: https://bug650088.bugzilla.mozilla.org/attachment.cgi?id=526719

thanks! will keep you posted.

Comment 14

7 years ago
(In reply to comment #12)
> (In reply to comment #11)
> > take it back.. it needs to be push to production by Friday and live date by
> > Monday, May 2nd. thanks.
> 
> This snippet's copy is final - but still waiting on an image and a link, no?
> Can't move ahead without those.

Assigning to Grace until all assets are ready.
Assignee: lforrest → gjimenez

Updated

7 years ago
Assignee: gjimenez → lforrest
Depends on: 652648

Updated

7 years ago
Assignee: lforrest → gjimenez
Created attachment 528367 [details]
ChannelSwitcher Promo Image

Let's use this image for this snippet. Thanks!

Comment 16

7 years ago
Link: http://support.mozilla.com/kb/how-do-i-switch-update-channels

Comment 17

7 years ago
Here are final assets. Waiting for Grace to give thumbs up for when this can go live.

Final Copy: Help us test the Channel Switcher: go to About Aurora and change
your channel to Beta. Thanks! _Learn more._

Link: http://support.mozilla.com/kb/how-do-i-switch-update-channels

Image: https://bug652121.bugzilla.mozilla.org/attachment.cgi?id=528367

Distribution: should be "aurora" and "product version" left
blank
(In reply to comment #17)
> Here are final assets. Waiting for Grace to give thumbs up for when this can go
> live.
> 
> Final Copy: Help us test the Channel Switcher: go to About Aurora and change
> your channel to Beta. Thanks! _Learn more._
> 
> Link: http://support.mozilla.com/kb/how-do-i-switch-update-channels
> 
> Image: https://bug652121.bugzilla.mozilla.org/attachment.cgi?id=528367
> 
> Distribution: should be "aurora" and "product version" left
> blank

Hi All, 

Slight change of plans from today.
Link change from the final assets list provided earlier.

Final assets: 

Final Copy: Help us test the Channel Switcher: go to About Aurora and change
your channel to Beta. Thanks! _Learn more._

Link: http://developer.mozilla.org/devnews/index.php/2011/04/27/aurora-channel-switcher-testing

Image: https://bug652121.bugzilla.mozilla.org/attachment.cgi?id=528367

Distribution: should be "aurora" only

still TBD on Live date. 

thanks!
(Reporter)

Comment 19

7 years ago
Live date is tomorrow.
(Reporter)

Comment 20

7 years ago
Live date is now pushed to Monday.
(Reporter)

Comment 21

7 years ago
This is likely going to happen late tonight, or tomorrow morning. I'll update once we know more.

Updated

7 years ago
Assignee: gjimenez → lforrest
Hi LauraF, 

Per our conversation, we just realized that the link has changed after blog post has been pushed live. 

Here is the final link: 
https://developer.mozilla.org/devnews/index.php/2011/05/04/aurora-channel-switcher-testing/

Please let me know how I can help in updating the snippet. thanks

Comment 23

7 years ago
Grace added in the snippet (thanks Grace!) and I created a new Match Rule and associated it to the snippet. Both are in staging and should be QA-ed before moved to production. 

Les - can you have a look, and push to production? Specifically that the snippet is loaded properly, and that the Match Rule works as intended (aurora channel only). Thanks!
Assignee: lforrest → lorchard
thanks lauraf! let me know if you need any additional info or how i can help!
(In reply to comment #23)
> Grace added in the snippet (thanks Grace!) and I created a new Match Rule and
> associated it to the snippet. Both are in staging and should be QA-ed before
> moved to production. 
> 
> Les - can you have a look, and push to production? Specifically that the
> snippet is loaded properly, and that the Match Rule works as intended (aurora
> channel only). Thanks!

hi les! please confirm once the snippet is pushed to production. thanks!
(Assignee)

Comment 26

7 years ago
(In reply to comment #25)
> (In reply to comment #23)

> > Les - can you have a look, and push to production? Specifically that the
> > snippet is loaded properly, and that the Match Rule works as intended (aurora
> > channel only). Thanks!
> 
> hi les! please confirm once the snippet is pushed to production. thanks!

I'm in portland this week for jsconf/nodeconf. Was out yesterday and have no wifi so far today. Can't preview snippets on my phone or manage them well. Probably won't get back to this until this afternoon / tonight.

Took a peek, though... noticed that both the preview-only and disabled checkboxes were on in staging. Have you guys seen this new snippet working in a browser yet? Can't push to production until the content has been vetted/QA'd on staging
(Assignee)

Comment 27

7 years ago
(In reply to comment #25)
 
> hi les! please confirm once the snippet is pushed to production. thanks!

Managed to get some wifi to check out the snippet. The HTML was invalid (missing a closing </a> tag for the link) and the preview & disabled boxes were checked. Fixed the HTML and enabled the snippet - seems okay in my browser now.

Please review on staging using the switcher addon and let me know if it's good to go for production.
(Assignee)

Comment 28

7 years ago
Created attachment 530394 [details]
screenshot of snippet in aurora

In case you have trouble using the switcher addon to try this (channel=aurora), here's a screenshot of how it looks in my copy of Aurora.
(Assignee)

Comment 29

7 years ago
(In reply to comment #28)
> Created attachment 530394 [details]
> screenshot of snippet in aurora
> 
> In case you have trouble using the switcher addon to try this (channel=aurora),
> here's a screenshot of how it looks in my copy of Aurora.

My wifi might go away soon for a few hours. So, since the snippet looks okay to me, I just imported it to production with fixes. We can disable/delete it quickly (even from my phone) if there's an issue
(In reply to comment #29)
> (In reply to comment #28)
> > Created attachment 530394 [details]
> > screenshot of snippet in aurora
> > 
> > In case you have trouble using the switcher addon to try this (channel=aurora),
> > here's a screenshot of how it looks in my copy of Aurora.
> 
> My wifi might go away soon for a few hours. So, since the snippet looks okay
> to me, I just imported it to production with fixes. We can disable/delete it
> quickly (even from my phone) if there's an issue

thanks les! 

lauraf, did we get that minor edit on production? taking out 'thanks'?

thanks everyone!

Comment 31

7 years ago
Looks good Les, thanks. 

I just removed the "Thanks". Closing this bug!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.