Move mozilla-{aurora,beta} repos on hg.m.o

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: joduinn, Assigned: noahm)

Tracking

Details

From discussion in yesterday's Aurora meeting, and also talking with NoahM today:

1) Please move:
http://hg.mozilla.org/mozilla-aurora --> http://hg.mozilla.org/releases/mozilla-aurora
http://hg.mozilla.org/mozilla-beta --> http://hg.mozilla.org/releases/mozilla-beta

2) Please create file level symlinks on hg.m.o pointing from old location to new location.
These symlinks will:
* allow developers who have a patch-in-progress to still be able to land the patch just fine. 
* allow releng automation to be changed with no/little disruption
* workaround a problem with web UI to hg.m.o. 
I'll file separate bug to track removing the symlinks after some time (~a month feels safe, but thats just a guess?).
What is the reasoning for this? The meeting notes just say "a bunch of good reasons", but I can't think of any. Doesn't seem right semantically and the moving cost is non-negligible (you'll have to keep the symlinks around indefinitely).
(In reply to comment #1)
> What is the reasoning for this? The meeting notes just say "a bunch of good
> reasons", but I can't think of any. Doesn't seem right semantically and the
> moving cost is non-negligible (you'll have to keep the symlinks around
> indefinitely).

1) Initial location of repos was setup at toplevel by accident, fixing sooner is better. Easier to setup hooks on these repos, and adjust permissions, with this directory structure. Also, allows easier organization of l10n repos, with similar hooks and similar directory structures.

2) We will not be keeping symlinks around for ever - the symlinks are only in place for this transition period. We will be deleting symlinks after transition period. Limited number of people doing changes on mozilla-aurora, mozilla-beta, so limited impact.

Comment 3

7 years ago
in the future, please try to give heads up based on the dependency chains which created the things you're trying to undo. mxr was in that chain so you should have given the owner of mxr a headsup by filing a bug, and ideally there should have been a reference to this bug in the bug which created the repositories you're moving so that anyone who was cc'd or otherwise following it would have been able to be alerted to this change.

Updated

7 years ago
Blocks: 654576

Comment 4

7 years ago
I just pushed to ssh://hg.mozilla.org/releases/mozilla-aurora/, and:
 * it didn't trigger builds
 * it didn't clear the hgweb cache for http://hg.mozilla.org/mozilla-aurora/ (though it did for releases/mozilla-aurora/)
Noah, could we change the post-commit hook that clears the varnish cache to do that for both /mozilla-aurora and /releases/mozilla-aurora/ ?
(Assignee)

Comment 6

7 years ago
It's been proposed on IRC that we use an HTTP redirect to move hg.m.o/mozilla-aurora to /releases/mozilla-aurora, instead of using a symlink.  This will eliminate the issue of having to clear the web cache of /mozilla-aurora and will get the aurora & beta repos off the top-level hgweb view while still allowing links to those URLs to work.

Give a yell if you object to this approach...
I think we still need a symlink for pushes until we're hard cutting over to releases/mozilla-aurora. 

There's some discussion here http://groups.google.com/group/mozilla.dev.planning/browse_thread/thread/cb71e091abfd66aa# in support of a long-term symlink.
(Assignee)

Comment 8

7 years ago
I've modified the hg hook responsible for purging the cached URLs such that pushes to either /releases/mozilla-aurora or /mozilla-aurora will cause both URL paths to be purged.  The same is true for mozilla-beta.

It would still be nice to investigate using a redirect in the future.
Depends on: 654626
Depends on: 654630
Noah, could the hook changes be the cause of messages like this at the end of a push:
 remote: warning: changegroup.z_purgeurl hook exited with status 1

That was me pushing to /users/mstange_themasta.com/tinderboxpushlog, but the same is also reported in bug 642536 comment #16 (along with a related issue).
(Assignee)

Comment 10

7 years ago
(In reply to comment #9)
> Noah, could the hook changes be the cause of messages like this at the end of a
> push:
>  remote: warning: changegroup.z_purgeurl hook exited with status 1

Sorry about that. Should be fixed.
WFM now.
Depends on: 655765
For anyone who made changes in this first aurora cycle, and also posted bugzilla links to a changeset in *old* repo location, IT are creating http redirects so that these bugzilla links will continue to work after the symlinks are deleted.
All done here. Thanks Noah.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.