Move of aurora and beta repositories into /releases/ broke branch detection for automation scripts

RESOLVED FIXED

Status

Mozilla QA Graveyard
Mozmill Automation
--
major
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: aaronmt, Assigned: whimboo)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

7 years ago
Created attachment 531080 [details]
screenshot

A user report in #mozmill attempted to run the extension in current builds of Aurora (5.0) which resulted in Mozmill Crowd attempting to switch to a non-existant test repository named 'mozillaaurora'. Unable to do so, this triggers no working test-run.

See screenshot of the users console log

Adding blocking 623204 (0.2)
(Reporter)

Updated

7 years ago
Target Milestone: --- → 0.2
I believe this has changed in the last week. Updating branch was 'aurora' not 'mozillaaurora'.
(Assignee)

Comment 2

7 years ago
This has nothing to do with the crowd extension. It's an issue with the automation scripts. The aurora repository has been moved into releases, which probably has been caused this issue on our side. Will check in a bit.
Status: NEW → ASSIGNED
Component: Mozmill Crowd Extension → Mozmill Automation
OS: Windows 7 → All
QA Contact: mozmill-crowd-extension → mozmill-automation
Hardware: x86 → All
Target Milestone: 0.2 → ---
(Assignee)

Updated

7 years ago
No longer blocks: 623204
(Assignee)

Comment 3

7 years ago
This will not only happen for builds on the aurora channel but also for builds on the beta channel. We have to fine-tune those channels now. I will have to check but it seems like there is no way to rename a named branch on Mercurial.
Blocks: 652229
Keywords: regression
Summary: Updating to a non-existant test repository on Aurora (5.0) named 'mozillaaurora' → Move of aurora and beta repositories into /releases/ broke branch detection for automation scripts
(Assignee)

Comment 4

7 years ago
Created attachment 531175 [details] [diff] [review]
Patch v1
Assignee: nobody → hskupin
Attachment #531175 - Flags: review?(gmealer)
(Assignee)

Comment 5

7 years ago
This is just a workaround for now. We will have to figure out how to better handle those branches across the board. We will have to discuss that beside. For now lets get this in ASAP so we can make sure to test builds on aurora and beta again.
Henrik, there was a problem with your patch upload; it's empty aside from contributor headers. Can you regen and reattach?
(Assignee)

Comment 7

7 years ago
Created attachment 531190 [details] [diff] [review]
Patch v1.1
Attachment #531175 - Attachment is obsolete: true
Attachment #531175 - Flags: review?(gmealer)
Attachment #531190 - Flags: review?(gmealer)
Comment on attachment 531190 [details] [diff] [review]
Patch v1.1

Looks like the return branch got clipped out. Also, as discussed on IRC, the regex will match '2.0' as well, so needs to be r'\D' instead.
Attachment #531190 - Flags: review?(gmealer) → review-
(Assignee)

Comment 9

7 years ago
Created attachment 531195 [details] [diff] [review]
Patch v2
Attachment #531195 - Flags: review?(gmealer)
(Assignee)

Updated

7 years ago
Attachment #531190 - Attachment is obsolete: true
Comment on attachment 531195 [details] [diff] [review]
Patch v2

Looks fine, r+. Thanks for the changes.
Attachment #531195 - Flags: review?(gmealer) → review+
(Assignee)

Comment 11

7 years ago
Landed as:
http://hg.mozilla.org/qa/mozmill-automation/rev/7717ca680fcd
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.