Closed Bug 652405 Opened 9 years ago Closed 9 years ago

All user fields (assignee, QA contact, Add CC) have the page title as the "title" attribute

Categories

(Bugzilla :: User Interface, defect)

defect
Not set
trivial

Tracking

()

RESOLVED FIXED
Bugzilla 4.0

People

(Reporter: deleeuw+bugzilla, Assigned: LpSolit)

References

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110423 Firefox/6.0a1
Build Identifier: 

All details in summary.

Reproducible: Always

Steps to Reproduce:
1. Open any bug report
2. Click the edit link for the CC List
3. Hover on the "Add" text box

Actual Results:  
– in title attribute

Expected Results:  
- in title attribute
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → 4.0
You are correct. 3.6 doesn't have this problem. So something regressed this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Target Milestone: --- → Bugzilla 4.0
The problem is that one parameter used in global/userselect.html.tmpl is "title". But "title" is already used to define the title of the HTML page, and so this parameter is implicitly passed to global/userselect.html.tmpl every time this template is called. This is a regression due to bug 578254.
Depends on: 578254
Summary: "Add" Textbox in CC List (click edit link to activate) has – in the title attribute → All user fields (assignee, QA contact, Add CC) have the page title as the "title" attribute
Attached patch patch, v1Splinter Review
I also fixed the wrong usage of ". You cannot use it here as the title is HTML filtered, and so is displayed as-is instead of being converted into a double quote.
Assignee: ui → LpSolit
Status: NEW → ASSIGNED
Attachment #527996 - Flags: review?(dkl)
Comment on attachment 527996 [details] [diff] [review]
patch, v1

Review of attachment 527996 [details] [diff] [review]:

Looks good to me. r=dkl
Attachment #527996 - Flags: review?(dkl) → review+
Flags: approval?
Flags: approval4.0?
Flags: approval?
Flags: approval4.0?
Flags: approval4.0+
Flags: approval+
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified template/en/default/global/userselect.html.tmpl
modified template/en/default/request/queue.html.tmpl
Committed revision 7787.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified template/en/default/global/userselect.html.tmpl
modified template/en/default/request/queue.html.tmpl
Committed revision 7576.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
deployed to production on bmo
You need to log in before you can comment on or make changes to this bug.