Last Comment Bug 652580 - Firefox 6.0a1 Crash Report [@ IsBreakElement ]
: Firefox 6.0a1 Crash Report [@ IsBreakElement ]
Status: RESOLVED FIXED
: crash, regression, reproducible
Product: Core
Classification: Components
Component: Spelling checker (show other bugs)
: Trunk
: All All
: -- critical (vote)
: mozilla6
Assigned To: :Ehsan Akhgari (out sick)
:
Mentors:
: 652481 652763 (view as bug list)
Depends on:
Blocks: 616684
  Show dependency treegraph
 
Reported: 2011-04-25 11:10 PDT by Marcia Knous [:marcia - use ni]
Modified: 2011-06-09 14:58 PDT (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Marcia Knous [:marcia - use ni] 2011-04-25 11:10:49 PDT
This bug was filed from the Socorro interface and is 
report bp-754bc3cc-0c40-4060-b2ee-eea172110425 .
============================================================= 

Seen while reviewing trunk crash stats. https://crash-stats.mozilla.com/report/index/754bc3cc-0c40-4060-b2ee-eea172110425 is one report.

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	IsBreakElement 	extensions/spellcheck/src/mozInlineSpellWordUtil.cpp:507
1 	xul.dll 	mozInlineSpellWordUtil::BuildSoftText 	extensions/spellcheck/src/mozInlineSpellWordUtil.cpp:569
Comment 1 Marcia Knous [:marcia - use ni] 2011-04-25 11:53:11 PDT
http://tinyurl.com/4xu9xcj links to the most recent crashes. This crash happens on Windows, Mac and Linux.
Comment 2 Marcia Knous [:marcia - use ni] 2011-04-25 12:03:08 PDT
*** Bug 652481 has been marked as a duplicate of this bug. ***
Comment 3 :Ehsan Akhgari (out sick) 2011-04-25 13:33:01 PDT
I managed to reproduce this when playing with Yandex search...
Comment 4 :Ehsan Akhgari (out sick) 2011-04-25 13:42:43 PDT
STR:

1. Search for something on Yandex.
2. on the results page, right click the search field, and check the Check Spelling menu item.
3. Edit the search query to make it incorrect as far as spelling is concerned.
4. Press back.  -> Crash.
Comment 5 :Ehsan Akhgari (out sick) 2011-04-25 14:07:36 PDT
Fixed by backout of bug 616684.
Comment 6 Henrik Gemal 2011-04-29 11:34:41 PDT
*** Bug 652763 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.