Create Firefox for mobile BETA logo for Android Market

RESOLVED FIXED

Status

Marketing
Design
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Caitlin Looney, Assigned: ibarlow)

Tracking

Details

Attachments

(7 attachments, 2 obsolete attachments)

(Reporter)

Description

7 years ago
To support rapid release channels, we'll need a Firefox for mobile BETA logo to include in our Android Market profile. 

Stuart - can you please provide the specs listed in the Android Market

We need the BETA in this lock-up to be prominent so users can clearly see the difference between BETA and Final when we're using Firefox logos for both profiles. 

Beta is expected to release in AM May 17.
(Reporter)

Comment 1

7 years ago
Another note - we need to make the logo different enough so if someone wants to install both beta and final on their phone, they can tell this difference.

Comment 2

7 years ago
Thanks Caitlin. As a background, the beta logo is identical to the general release one, so we should focus on ways we can use text to call out the differences here. For example, if someone has both products installed on their phone, can we have the descriptive text beneath read Firefox and Firefox Beta?

We'll definitely need those specs from the Android Market to proceed here, as well as any other info about sizes and contexts that are relevant (such as the use case above about having both versions installed next to each other).

Do you know how much in advance of May 17 the Android Market will need the new logo for inclusion there?

Comment 3

7 years ago
- in addition to using text as a differentiator, what would be the possibility of looking into having a different logo for mobile beta specific, like we do with nightly and aurora for desktop?

Comment 4

7 years ago
My thought on that would be to use the actual Nightly and Aurora logos on mobile and retire the Fennec logo altogether.
(Reporter)

Comment 5

7 years ago
We can update the profile within minutes, so we won't need much lead time (at all). We'll need those specs and play around with what we can do. We need this from Stuart as he's the only one with access to this info.

I think we really need to investigate a different treatment of the Firefox Beta logo as people 1) don't read 2) needs to be more clear in Android Market and 3) could easily have both beta and final on their devices. Beta won't be as locked and loaded as our Betas in the past, so we really should look into altering the logo. That said, let's see what Stuart can provide re text parameters and naming the file.

Comment 6

7 years ago
We'd need to create a new logo for Beta on mobile as changing the Firefox logo itself shouldn't be an option. 

That said, I'm a +1 on John's comment about changing the text as I don't think we'd want to introduce a new brand mark if we already have a system in place on desktop. 

I think aligning mobile's branding with the channel name/logo system of desktop would help us more than hinder us here.

Comment 7

7 years ago
one thing we can do for sure is make a special treatment for the logo within the Android Market itself (ie. have the word "beta" vertical next to it)
Created attachment 528254 [details]
Firefox Logo wit BETA text (vertical)

For the Android Market, something like the attached logo should do: the standard logo and the text "BETA". However, that probably does not solve the issue with users needing to differentiate Beta vs. Full Release form the icon on their mobile desktop. Thanks!

Comment 9

7 years ago
Agreed with what Sean wrote in comment #6 and comment #7. As far as differentiating on the mobile desktop goes, what about what I suggested re: descriptive text in comment #2?

Comment 10

7 years ago
Out of curiosity, are there references from other brands that we can use for inspiration here?  others who are doing a good job of addressing this same problem -- differentiating the RC and Beta as desktop icons?

Comment 11

7 years ago
sorry, meant to simply refer to icons, not specifically desktop icons...
(Reporter)

Comment 12

7 years ago
First and foremost apps are adding "Beta, BETA, or (Beta)" at the end of each title. Most don't change the icon at all and just add the copy in the title.

-Angry Birds users the same logo but puts a "beta" ribbon banner around the bottom left corner of the logo. 

-Starbucks puts "BETA" right over the Drink Caller logo.

-Dolphin browser also puts a little ribbon banner to decipher between mini and HD.

-Opera user the same logo for Opera Mobile and Opera Mini Web Browser and just uses copy to get their message across.
(Reporter)

Comment 13

7 years ago
In sum, it runs the gammut, but my recommendation based on clarity and aethetics would be:

Mozilla Firefox Web Browser  (final)
Mozilla Firefox BETA (beta) + Firefox logo with "Beta" banner over the bottom corner.
(Reporter)

Comment 14

7 years ago
*gamut

Irina - Any thoughts on the matter?

Comment 15

7 years ago
I think that if we want to explore adding a beta banner over a corner we should investigate it as a general option for product betas, which may be applied or not, according to necessity.  As we are exploring alternative distribution channels for Firefox, this is be something we will need to reproduce. 
 

If we only want to change the wording, then for the icon on the device we can change the name of the app to "Firefox BETA". This would work for a large part of the users, but not for the ones who use some custom launchers or on certain devices. 

For the beta channel another thing we should pay attention to is discoverability. For a while after launch Opera Mobile's beta version was the first on search results, before the final version. I think we are safe from that, having had the final version for a while in the market, but we need to make sure our search optimization for the beta does not overtake the final version.

Comment 16

7 years ago
It seems like we're going in the right direction here, but I'd love to hear Sean's take.

Sean, thoughts?

Comment 17

7 years ago
Sounds good. 

I can create a graphic for the Market. What are the required dimensions?

Updated

7 years ago
Assignee: tshahian → smartell
(Reporter)

Comment 18

7 years ago
Stuart - can you please provide the required dimensions?
(Reporter)

Comment 19

7 years ago
Stuart - can you please provide the required dimensions?
from http://market.android.com/support/bin/answer.py?answer=1078870

High Resolution Application Icon (Required):

    Use: In various locations in Android Market.
        Does not replace your launcher icon.
    Specs: 512x512, 32-bit PNG with alpha; Max size of 1024KB.
    Tips:
        This does not replace your launcher icon, but should be a higher-fidelity, higher-resolution version of your application icon.
        Same safe-frame as current launcher guidelines, just scaled up:
            Full Asset: 512 x 512 px.
            Circle or non-square icons: 426 x 426 px, centered within the PNG.
            Square Icons: 398 x 398 px.
        Drop shadow: black, 75% opaque, 90 degrees down, distance of 14px, size of 36px.
            Tweak as necessary to fit icon style (e.g., Google Maps icon has a drop shadow of varying height).

Promotional Graphic (Optional):

    Use: In various locations in Android Market.
    Specs: 180w x 120h, 24 bit PNG or JPEG (no alpha), Full bleed, no border in art.

Feature Graphic (Optional):

    Use: The featured section in Android Market. Will be downsized to mini or micro.
    Specs: 1024w x 500h, 24 bit PNG or JPEG (no alpha) with no transparency
    Tips:
        Use a safe frame of 924x400 (50 pixel of safe padding on each side). All the important content of the graphic should be within this safe frame. Pixels outside of this safe frame may be cropped for stylistic purposes.
        If incorporating text, use large font sizes, and keep the graphic simple, as this graphic may be scaled down from its original size.
        This graphic may be displayed alone without the app icon.
(Reporter)

Comment 21

7 years ago
Hey Sean - 

Please provide some options as soon as you have them. I think the team has a preference to a banner over the corner of the logo as "beta" may be difficult to read.
Bug 654838 has the needed branding changes needed for beta. Any in-product
image and icon changes need to be added to that bug.
Depends on: 654838
(Reporter)

Comment 23

7 years ago
Hey Slater - Spoke to Stuart and he's asked to get these options by Wednesday (May 11) of next week so we have enough time to test it on various screen, etc. Please assign this to Ian or Sean, or maybe they can work together.
Assignee: smartell → ibarlow

Comment 24

7 years ago
Some thoughts:

- if "beta" will be difficult to read, what will be on the banner?
- is the word "beta" ok with localization as it won't change?

Having a banner obscuring a portion of the logo with nothing on it isn't ideal. 

I'm a bit concerned about having mobile treat the logo differently than desktop. Changing live text is easy, introducing a new brand scheme is not.

Comment 25

7 years ago
A couple thoughts from me:
- we should be treating this like a promo graphic rather than a new variation on the logo itself. That distinction feels clear in my mind, but let me know if I should elaborate.
- would like to find a way to do this without covering up the logo too much with a banner...that seems like it would be a little awkward.

Sean, Ian...what do you think?
(Assignee)

Comment 26

7 years ago
Hi guys

So, I tend to agree with Sean, that we've already established a way we talk about Beta for desktop. Rather than creating a one-off treatment just for phones and tablets, would it not just make sense to add the word "beta" to the actual name of the app, both in the store and on the device? Wouldn't that be clear enough for people? Like this: 

Android Market - Search Results
http://www.flickr.com/photos/61892693@N03/5693522365/in/set-72157626661581732

Android Market - Item Page
http://www.flickr.com/photos/61892693@N03/5694093424/in/photostream

Android Phones - A Beta app next to a normal app
http://www.flickr.com/photos/61892693@N03/5694093382/in/set-72157626661581732/

What do you guys think?
(Reporter)

Comment 27

7 years ago
Adjusting copy is fine with me (this is what Opera does), but people felt like there would still be confusion and thus, the reasoning for treating the logo a bit differently. Can we attempt this so we can appease concerned parties and we can do a side-by-side? I agree that this is clear, but want others to buy in as well.
To be clear, my concern is that simply appending "beta" to the name and/or icon isn't strong enough since most users don't understand what "beta" means. I don't know that I care one way or the other if we slap "beta" on the name versus on the logo.

For background on my concerns, the difference between desktop and mobile in this case is that to download desktop builds users have to click through multiple levels of the website and are routinely asked "are you sure you don't want the release version" before they can download the beta. In the android market they're presented on the same footing, so I think there needs to be a stronger differentiation in how we present it.
(Reporter)

Comment 29

7 years ago
I agree and we'll be doing this with title, description, possibly logo too, app name on device, during first-run and in Input.

Comment 30

7 years ago
I do not think that adding beta to the name alone is enough.  The icon needs to be different.

Comment 31

7 years ago
We've already made a product branding decision to use the same basic logo for beta & general release (ex. http://www.mozilla.com/en-US/firefox/channel/) so actually having a different icon isn't on the table.

Before we were discussing having some visual treatment around, or possibly even over, the logo...we could continue to explore that, but I have to say that personally Ian's suggestion in comment #26 seems pretty clear to me.

Comment 32

7 years ago
Where did we net out on this?
(Reporter)

Comment 33

7 years ago
Your last comment (#31) looks like you decided not to entertain any different treatments of the logo.

Comment 34

7 years ago
What is the status here?  Do we have a new logo yet?  I am not ok with us shipping beta with the exact same logo we use for release.

Comment 35

7 years ago
After some discussion between the product marketing, product UX and creative teams, here's where we wound up:

Let's add a 'beta' banner to the logo in the Android marketplace and on phone desktops. It'll look something like http://cl.ly/2r20160T1n3w1o0a120Q and http://cl.ly/3f2d3z3I0D2O1o0C1x1K. 

To be clear, these are the *only* places that will feature this banner for the time being. This isn't a full-fledged logo change, in other words...more of a contextual adjustment.

Going forward, we'll continue to evaluate how we treat the betas...ideally any changes would be made across both desktop and mobile, but this seems like the best solution for now (given the immediacy of this particular need).

The links above are just for reference...Ian will be posting actual files here soon.
(Assignee)

Comment 36

7 years ago
Created attachment 531747 [details]
Firefox Beta Logo for Android Market
Attachment #528254 - Attachment is obsolete: true
(Assignee)

Comment 37

7 years ago
Created attachment 531751 [details]
Firefox (full version) logo for Android Market
(Assignee)

Comment 38

7 years ago
Hi all,

I've attached a Beta logo for use on the Android Market pages. Also here is a slightly updated full version logo, where we've fixed an issue we noticed with the shadow. 

NOTE: these are _not_ icons for the app launcher, they are for Android Market only. The app launcher icons will follow shortly.
(Assignee)

Comment 39

7 years ago
Created attachment 531913 [details]
Firefox Launcher icons (beta and full versions)

Hi all, here are the new launcher icons for android. Included are Beta and full versions for HDPI and MDPI devices. :)

Ian
(Assignee)

Comment 40

7 years ago
Created attachment 531933 [details]
Firefox Launcher icons (beta and full versions)

Attached are updated (embiggened) launcher icons for HDPI and MDPI
Attachment #531913 - Attachment is obsolete: true
(Assignee)

Comment 41

7 years ago
Created attachment 531936 [details]
Firefox Beta Launcher icons

Attached are just the beta launcher icons. (The original app launcher icons do not need to be updated anymore.)
Added patch in bug 654838. It has the needed bugzilla flags to get the patch landed on aurora
Blocks: 657534
(Reporter)

Comment 43

7 years ago
Hey - Android Market ask for  high res (512x 512 32 bit PNG or JPG) as well as a promo graphic ( 180x120 24 bit PND or JPG). Ian's attachment shows these at 48x48 and 72x72. Will these suffice?
(In reply to comment #43)
> Hey - Android Market ask for  high res (512x 512 32 bit PNG or JPG) as well
> as a promo graphic ( 180x120 24 bit PND or JPG). Ian's attachment shows
> these at 48x48 and 72x72. Will these suffice?
I don't think those will suffice, let's get some full resolution images.
(Reporter)

Comment 45

7 years ago
Thanks a ton!
(In reply to comment #43)
> Hey - Android Market ask for  high res (512x 512 32 bit PNG or JPG) as well
> as a promo graphic ( 180x120 24 bit PND or JPG). Ian's attachment shows
> these at 48x48 and 72x72. Will these suffice?

You are looking at the wrong attachments. See:
https://bugzilla.mozilla.org/attachment.cgi?id=531747 (512x512)
(Reporter)

Comment 47

7 years ago
Hi Ian, Finkle or Brad -

We're still looking for an attachment for the promo graphic (Specs: 180w x 120h, 24 bit PNG or JPEG). There are a lot of attachments that I've been through and I don't see an image that aligns thus far. Please advise.
(In reply to comment #47)
> Hi Ian, Finkle or Brad -
> 
> We're still looking for an attachment for the promo graphic (Specs: 180w x
> 120h, 24 bit PNG or JPEG). There are a lot of attachments that I've been
> through and I don't see an image that aligns thus far. Please advise.

The specs say it's optional. No biggie. Ian can make one.
(Reporter)

Comment 49

7 years ago
Hey Sean - Would you be able to provide a new promo graphic for us?
According to the ever-so-helpful market docs, the Promo graphic is used "In various locations in Android Market."

At present, the install view logo icon for the Firefox Beta is very tiny and since there is no setting anywhere for that I am curious to know if it's related to having a Promo Graphic. Firefox 4.0.1 has one.

So if we can get a promo graphic and try uploading that to see if it helps that would be good information to have.  I'll attach a screenshot of the issue.
Created attachment 534158 [details]
screenshot of the tiny logo currently in the android market install view - without promo graphic on file

Comment 52

7 years ago
Ian, are on on this one?

Comment 53

7 years ago
"are you on this one" I meant to say. Apologies for the bugspam.
(Assignee)

Comment 54

7 years ago
Hi John, yes in fact I sent some options to Martell earlier this morning and he was going to connect with you about them. Here's the link to the options:

http://www.cl.ly/281f0c0s3f0O0d3S010O

and an example of where they live:
http://www.cl.ly/3n0o0i08050X0a0U1R34

Let me know where you end up and I can send out the graphics right away :)

Comment 55

7 years ago
I'd go with A for cleanliness and Slater gives a +1 to that.

My only other thought was to add the wordmark underneath, but we're not final on those, so A is a good solution. We can update at a later date once we get the brand toolkit finalized.

Comment 56

7 years ago
Agreed, thanks Ian!
(Assignee)

Comment 57

7 years ago
Created attachment 534834 [details]
Android Market Promo Graphics

Hi all, attached are Full and Beta versions of the 180x120 Android market promo graphic. 

Let me know if there's anything else you need!

Ian
Can we try to add the Beta version of the Promo graphic from Comment 57 to the Android Market, to replace the tiny app logo by a larger one?
(In reply to comment #58)
> Can we try to add the Beta version of the Promo graphic from Comment 57 to
> the Android Market, to replace the tiny app logo by a larger one?

I had mentioned this to Caitlin in IRC, sorry for not documenting it in here as well.  To put up the Promo Graphic, you have to have Promo Text. I had English Promo Text but when I tried to put that in I discovered that makes localized Promo Text suddenly required. I had asked Caitlin who should be contacted to get the Promo Text localized in order to update the Promo Graphic and was waiting on a response.
(Reporter)

Comment 60

7 years ago
Hi Lukas, I didn't get that comment from you.

I can file a bug to get the promo text localized, but can you double check on that. The print out of the descriptions that Stuart gave me reads that the promo text is "English only."
(In reply to comment #60)
> Hi Lukas, I didn't get that comment from you.
> 
> I can file a bug to get the promo text localized, but can you double check
> on that. The print out of the descriptions that Stuart gave me reads that
> the promo text is "English only."

When I entered the text and tried to save it would not allow me to do so without that text field filled out for each locale.
(Reporter)

Comment 62

7 years ago
Ok, I'll file a bug. I wonder how we're doing it for 4.0.1 as there is only English promo text.
(In reply to comment #62)
> Ok, I'll file a bug. I wonder how we're doing it for 4.0.1 as there is only
> English promo text.

There is translated text in the locales for 4.0.1 Promo Text.
Created attachment 536889 [details]
promo text locale example

for an example of the fields for a listing's language.
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.