New kinetic panning should not open side panels

RESOLVED DUPLICATE of bug 521113

Status

--
major
RESOLVED DUPLICATE of bug 521113
8 years ago
8 years ago

People

(Reporter: tarend, Unassigned)

Tracking

Trunk
ARM
Android

Details

(Reporter)

Description

8 years ago
(1) go to nyt.com or any other web page that allows zooming in
(2) zoom in a little bit
(3) flick page to either of the sides, left or right

Result: Page zooms smoothly, even after lifting your finger (as expected) but zooms right into the side panel
Expected: panning should NOT open the side panel after finger is lifted
I disagree, first because I personally rely on this behavior in my daily browsing. Second, because I think making this change will significantly reduce the discountability of the sidebars
changing the summary to reflect what you described in the description
Summary: New panning should not open side panels → New kinetic panning should not open side panels
(Reporter)

Comment 3

8 years ago
Sorry, Brad. But this is a regression. We worked **** making the side bars NOT pop up accidentally as you scroll and pan. Brian is working in discoverability separately. So we will have great ways of teaching users how to find and use our side bars, bookmarks, etc. The panes should *not* open during normal panning and scrolling.
do you have a regression range?
I'll see if I can find one.
Keywords: regressionwindow-wanted
I can't see a difference between 4 behavior and trunk behavior. The more fluid scrolling on the trunk may have made this more noticeable
The hard part, of course, is clarifying what we mean by "normal panning and scrolling." You _do_ open the sidebars by panning to them - that's how they open.

Thomas - do you mean that there doesn't seem to be enough resistance to the edge, such that a small pan takes you all the way over into a sidebar?
(Reporter)

Comment 8

8 years ago
The difference should be this: if I keep holding my finger down while panning, I probably want to open the sidebar. A small resistance would be nice to have, but it not required. 
In the current case you actually "flick": you start panning, LIFT your finger, and watch the page scroll to the side and open the sidebar. In that case you probably didn't want to open the sidebar since you lifted your finger *before* you reach the edge. Try it for yourself and you will see what I mean.
The assumption you're making is that if your finger is off the screen you don't want to open the sidebars. I disagree with that assumption and the resulting opinion.

I can agree with adding some strong resistance to the sidebars, but a strong kinetic pan should be able to open the sidebar.
Keywords: regressionwindow-wanted
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 521113
You need to log in before you can comment on or make changes to this bug.