Thunderbird crashes randomly on open-file or save-file dialog for attachment. multiple crash sigs [@ thumbcache.dll@0x178b ], [@ CThumbnailCacheDataFile::_CloseMapping() ], [@ CFrame::ClearLastError() ]

RESOLVED DUPLICATE of bug 539813

Status

defect
--
critical
RESOLVED DUPLICATE of bug 539813
8 years ago
8 years ago

People

(Reporter: a.topp, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, )

Reporter

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16
Build Identifier: Thunderbird 3.1.9 (german)

i'm runnig a windows terminal server (2008 R2) with Thunderbird 3.1.9. There are about 25 Users at the Moment.

They users reported crashes on saving attachments or add attachments.

The Crashes happens directly after the open/save file-dialog from the os was shown up.
when this problem occurs i can reproduce the crash by just starting TB again, and do the same steps. After some tries, without changing something, the Crash dissapears.

I think it could be a timeout or something like that causing the crash, which is a bit to short. The user-profiles on the terminal-server are locatet on a DFS-Share throuhg folder redirection, maybe the last folder of "attach.dir" cannot be read fast enough.

My intention is, that somebody writes a error-handling on that. if somewhere in the file-dialog occurs an error, thunderbird crashes totally, and any composed, not saved mails, are destroyd.
an error-handling on that situastion would prevent from crash and could help to find out the exact cause of the problem.

sorry for my bad english.

Reproducible: Sometimes
please post crashreport ID.
 process described at https://support.mozillamessaging.com/en-US/kb/Thunderbird+crashes
Keywords: crash
Summary: Thunderbird crashes randomly on open-file or save-file-dialo → Thunderbird crashes randomly on open-file or save-file dialog for attachment
Whiteboard: dupeme
Reporter

Comment 2

8 years ago
Add-ons: {972ce4c6-7e08-4474-a285-3208198ce6fd}:3.1.9
BuildID: 20110303033424
CrashTime: 1303284294
EMCheckCompatibility: true
FramePoisonBase: 00000000f0de0000
FramePoisonSize: 65536
InstallTime: 1299489986
ProductName: Thunderbird
ReleaseChannel: release
SecondsSinceLastCrash: 64413
StartupTime: 1303284201
Theme: classic/1.0
Throttleable: 1
URL:
Vendor:
Version: 3.1.9

Diese Meldung enthält Informationen über den Status der Anwendung zum Zeitpunkt des Absturzes.
Reporter

Comment 3

8 years ago
this is all information i have from the last crash. i will update this, at the next time the error occurs! thanks.
Thanks Andreas, but what you posted is not a "report ID". it should be BP-nnnn...

please check the documents again.
Reporter

Comment 5

8 years ago
here some crash-id's:
bp-71d2489b-e86b-416b-83fa-83e972110502
bp-f94e05f1-d38f-482d-bcb8-9a3e12110502
bp-2f3876f2-e7ba-4ba9-ba6f-d5d6e2110411
bp-a4e04f84-5822-4ac8-b327-b63ea2110406

probably they should all depend on the described bug - the two on the top are definitly from the described bug!
Reporter

Comment 6

8 years ago
i can give a lot of more, if needed and helpfull.
(In reply to comment #6)
> i can give a lot of more, if needed and helpfull.
Are they all related to the same actions leading to a crash ? ( I'm asking because all the crash signature are very different)
Whiteboard: dupeme
(In reply to comment #5)
> here some crash-id's:
> bp-71d2489b-e86b-416b-83fa-83e972110502
> bp-f94e05f1-d38f-482d-bcb8-9a3e12110502
> bp-2f3876f2-e7ba-4ba9-ba6f-d5d6e2110411
> bp-a4e04f84-5822-4ac8-b327-b63ea2110406

All these crashes seem to be system crashes none of them related to thunderbird - very weird.
Reporter

Comment 9

8 years ago
here are some additional crash-report-id's from another user on the same system:

bp-3d2f8ec1-19f9-4edc-98b8-a109c2110405
bp-6dfd3677-5010-49cd-91cf-6c5212110405
bp-652b55d5-9c8e-40ef-9c38-363272110408
bp-9844fcad-8275-485a-a372-8cf592110427
bp-d4592c80-3662-4d59-852e-955072110420

and here from another user:
bp-2222fa33-a88a-4d24-8952-c38d42110401
bp-d2ae8a77-da78-4138-8ae6-eca592110401
bp-feddc0f2-4ef4-4fc1-94be-fd52c2110330

do you need more? 
i dont know for sure if all crashes related to the same actions, but i think so. the users didn't report me any other situation when crashing, and everytime i checked it, it was the problem described on top.

i hope this helps to solve the problem.
yeah. small sample
- thumbcache.dll  bug 539813  = invalid
- fundisc.dll  no bug match
- SearchFolder.dll  no bug match
Reporter

Comment 11

8 years ago
sorry Wayne, 
i don't understand what you mean.
sorry. what i mean is it helps. The crashes are indeed all related to attach and the dll's cited.  But this isn't an area where I have much experience. 

However, I'd think this is a duplicate
Whiteboard: [dupeme?]
Reporter

Comment 13

8 years ago
you mean, the bug was already postet earlier? or do you mean, the crash-report-id's i posted are duplicates?
(In reply to comment #13)
> you mean, the bug was already postet earlier? or do you mean, the
> crash-report-id's i posted are duplicates?

I think it may match an existing bug report. bug list: https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=substring&order=Last%20Changed&list_id=371897&short_desc=attach&field0-0-0=product&type0-0-1=substring&field0-0-1=status_whiteboard&type1-0-1=anywordssubstr&resolution=---&resolution=FIXED&resolution=INVALID&resolution=DUPLICATE&resolution=WORKSFORME&value1-0-1=crash%20segfault&classification=Client%20Software&classification=Components&value0-0-2=thunderbird&chfieldto=Now&query_format=advanced&chfieldfrom=2010-01-01&value1-0-0=crash&short_desc_type=allwordssubstr&field0-0-2=short_desc&value0-0-1=tbird&type0-0-0=anywordssubstr&value0-0-0=mailnews%20thunderbird&field1-0-0=keywords&product=Core&product=MailNews%20Core&product=Thunderbird&type0-0-2=substring&field1-0-1=short_desc

But that's just a gut feel, and I could be wrong. can you dig up some dirt on thumbcache.dll?  And test whether the problem goes away when using terminal server if the profile is *not* on a redirect or share?
Summary: Thunderbird crashes randomly on open-file or save-file dialog for attachment → Thunderbird crashes randomly on open-file or save-file dialog for attachment. multiple crash sigs [@ thumbcache.dll@0x178b ], [@ CThumbnailCacheDataFile::_CloseMapping() ], [@ CFrame::ClearLastError() ]
Reporter

Comment 15

8 years ago
i think the link is wrong? 

anyhow, what do you mean with "dig up some dirt on thumbcache.dll"? i don't know the meaning of dig up some dirt.

it's difficult to test, because i found no way to reproduce the crash and i cannot disable the redirection of the home-dirs for a long time. 

i think the error occurs when TB tries to acces a folder, to which the user has no access for a moment, so if i would disable the redirection, the problem maybe would not occur again, but this would be no solution, and anyway the bug of TB would still exist.
(In reply to comment #15)
> i think the link is wrong? 

shorter: http://bit.ly/lAsLYG


> anyhow, what do you mean with "dig up some dirt on thumbcache.dll"? i don't
> know the meaning of dig up some dirt.

"dig up dirt" =  find out what it does (via google or other means), and whether there are known issues with it :)  


> it's difficult to test, because i found no way to reproduce the crash and i
> cannot disable the redirection of the home-dirs for a long time. 
> 
> i think the error occurs when TB tries to acces a folder, to which the user
> has no access for a moment, so if i would disable the redirection, the
> problem maybe would not occur again, but this would be no solution, and
> anyway the bug of TB would still exist.

I don't understand why you say that - we don't know if  disabling redirect will help or not, do we?  Anyway, tests are temporary, for debugging. The solution does not come until we know WHY it is happening. And because no one has figured out what is wrong by usign the crash report, we must determine what reproduces the problem (or doesn't). 

And the only person in a position to test  combinations of factors to help narrow the scope of the problem is you :)
fine tuning the query, the match is easily found - Bug 539813 - Crash in [@ thumbcache.dll@0x1f34] when attempting to save or attach files. Also [@ thumbcache.dll@0x14c1 ], [@ thumbcache.dll@0x1f1d ], [@ thumbcache.dll@0x1f6f ]
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 539813
Whiteboard: [dupeme?]
Crash Signature: [@ thumbcache.dll@0x178b ] [@ CThumbnailCacheDataFile::_CloseMapping() ] [@ CFrame::ClearLastError() ]
You need to log in before you can comment on or make changes to this bug.