Last Comment Bug 653321 - Add disk image (DMG) background for non-official branding OS X downloads
: Add disk image (DMG) background for non-official branding OS X downloads
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: unspecified
: All Mac OS X
: -- normal with 1 vote (vote)
: Firefox 7
Assigned To: Stephen Horlander [:shorlander]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-27 18:46 PDT by Justin Dolske [:Dolske]
Modified: 2011-07-07 06:48 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Aurora DMG Background (91.18 KB, image/png)
2011-04-29 07:50 PDT, Sean Martell
no flags Details
Nightly DMG Background (85.77 KB, image/png)
2011-04-29 07:51 PDT, Sean Martell
no flags Details
Update DMG Background WIP (224.07 KB, patch)
2011-05-11 09:58 PDT, Stephen Horlander [:shorlander]
gavin.sharp: feedback-
Details | Diff | Splinter Review
Update DMG Background WIP - 02 (224.65 KB, patch)
2011-05-11 13:34 PDT, Stephen Horlander [:shorlander]
gavin.sharp: review+
Details | Diff | Splinter Review

Description Justin Dolske [:Dolske] 2011-04-27 18:46:15 PDT
Downloading the OS X for a "Firefox" (stable) build gives you a nice background in the Finder window:

http://mxr.mozilla.org/mozilla-central/source/browser/branding/official/background.png

(Note important arrow image that indicates one should drag the app to the applications folder link.)


For our other branding flavors, it's just a blank image. It's ugly.

http://mxr.mozilla.org/mozilla-central/source/browser/branding/unofficial/background.png
http://mxr.mozilla.org/mozilla-central/source/browser/branding/aurora/background.png
http://mxr.mozilla.org/mozilla-central/source/browser/branding/nightly/background.png

We should at least use the nice background from the official/ branding sans wordmark. Bonus for putting the appropriate workmark into place. Hopefully the original artwork for that exists somewhere?
Comment 1 Justin Dolske [:Dolske] 2011-04-27 18:48:00 PDT
(The icon for the DMG itself is also wrong, but bug 649526 looks to be taking care of that)
Comment 2 Alex Faaborg [:faaborg] (Firefox UX) 2011-04-28 12:32:34 PDT
For Nightly and Aurora we should be using stars :)  That way you get to drag the planet around in it's correct solar context!
Comment 3 Sean Martell 2011-04-29 07:50:48 PDT
Created attachment 529095 [details]
Aurora DMG Background
Comment 4 Sean Martell 2011-04-29 07:51:16 PDT
Created attachment 529096 [details]
Nightly DMG Background
Comment 5 Sean Martell 2011-04-29 07:51:38 PDT
Enjoy! :)
Comment 6 Alex Faaborg [:faaborg] (Firefox UX) 2011-04-29 12:48:33 PDT
<3
Comment 7 Justin Dolske [:Dolske] 2011-05-01 23:10:52 PDT
Just for completeness's sake, can we get a simple version for the "unofficial" branding? Looks like it doesn't even need a wordmark, going from what we did with splash.bmp...

http://mxr.mozilla.org/mozilla-central/source/browser/branding/unofficial/splash.bmp

[Not sure if we'll even be using this branding flavor in the future, it used to be for the park-named alpha releases. But I'm assuming it should be trivial enough to make a plain/bland/mspaint version.]
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-04 09:02:28 PDT
I tried doing the obvious and replacing the existing background.pngs with those files, and for some reason the DMG I got from a "make package" still didn't include them (even after a clobber). I'm not sure what's going on with that.
Comment 9 Stephen Horlander [:shorlander] 2011-05-04 09:11:15 PDT
(In reply to comment #8)
> I tried doing the obvious and replacing the existing background.pngs with those
> files, and for some reason the DMG I got from a "make package" still didn't
> include them (even after a clobber). I'm not sure what's going on with that.

Probably a problem with the dsstore file. Looks like the one in the Nightly directory is still referencing DeerPark. Not sure how those were made to being with. Probably manually created by editing a DMG then copied over?
Comment 10 Stephen Horlander [:shorlander] 2011-05-11 09:58:04 PDT
Created attachment 531661 [details] [diff] [review]
Update DMG Background WIP

This patch updates the background image and the dsstore file. Only tested on 10.6.
Comment 11 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-11 10:57:44 PDT
Comment on attachment 531661 [details] [diff] [review]
Update DMG Background WIP

This looks great on 10.6, but doesn't work on 10.5.
Comment 12 Stephen Horlander [:shorlander] 2011-05-11 13:34:05 PDT
Created attachment 531730 [details] [diff] [review]
Update DMG Background WIP - 02

Updated to work on 10.5
Comment 13 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-11 16:04:11 PDT
Comment on attachment 531730 [details] [diff] [review]
Update DMG Background WIP - 02

There is some weirdness on 10.5 if hidden files are visible (scrollbars appear), but that's not a major issue.

The background and the icon kind of blend together to some degree, which is a bit odd, but apparently the icon will be changing to work better in that case. I didn't check that the alignment was pixel perfect, but this is certainly better than the current setup :)
Comment 14 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-06-28 13:01:45 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/f04f67e0b5fe
Comment 15 Joe Drew (not getting mail) 2011-06-28 18:57:57 PDT
http://hg.mozilla.org/mozilla-central/rev/f04f67e0b5fe
Comment 16 Simona B [:simonab ] 2011-07-07 06:48:17 PDT
Verified fixed on:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0a2) Gecko/20110706 Firefox/7.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0a1) Gecko/20110707 Firefox/8.0a1

Note You need to log in before you can comment on or make changes to this bug.