Last Comment Bug 653408 - OTS sanitizer incorrectly drops OpenType Layout tables from LinLibertine_Re-4.7.5(.ttf/.woff)
: OTS sanitizer incorrectly drops OpenType Layout tables from LinLibertine_Re-4...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Jonathan Kew (:jfkthame)
:
Mentors:
Depends on:
Blocks: 653100
  Show dependency treegraph
 
Reported: 2011-04-28 05:20 PDT by Jonathan Kew (:jfkthame)
Modified: 2011-05-02 02:16 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch, fix the table size computation in gdef.cc (883 bytes, patch)
2011-04-28 05:20 PDT, Jonathan Kew (:jfkthame)
jd.bugzilla: review+
Details | Diff | Review

Description Jonathan Kew (:jfkthame) 2011-04-28 05:20:12 PDT
Created attachment 528827 [details] [diff] [review]
patch, fix the table size computation in gdef.cc

The OTS sanitizer drops the OTL tables from LinLibertine, which happens to be a font we use in our font-feature reftests. This caused reftests to turn orange when I tried to land bug 653100.

This is because of a typo in the OTS 'GDEF' parser, which causes it to incorrectly conclude that the LigCaretListTable is bad.

Reported upstream as http://code.google.com/p/chromium/issues/detail?id=80797.
Comment 1 Jonathan Kew (:jfkthame) 2011-05-02 02:16:05 PDT
http://hg.mozilla.org/mozilla-central/rev/f1267acf58cf

Note You need to log in before you can comment on or make changes to this bug.