Last Comment Bug 653100 - remove redundant storing of OpenType table copies, now that OTS doesn't discard them
: remove redundant storing of OpenType table copies, now that OTS doesn't disca...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Jonathan Kew (:jfkthame)
:
: Milan Sreckovic [:milan]
Mentors:
Depends on: 643460 653408
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-27 06:18 PDT by Jonathan Kew (:jfkthame)
Modified: 2011-05-02 02:17 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch, remove code to save copies of layout tables prior to OTS sanitization (8.16 KB, patch)
2011-04-27 06:18 PDT, Jonathan Kew (:jfkthame)
no flags Details | Diff | Splinter Review
patch, remove code to save copies of layout tables prior to OTS sanitization - merged to tip (8.25 KB, patch)
2011-04-27 22:41 PDT, Jonathan Kew (:jfkthame)
jd.bugzilla: review+
Details | Diff | Splinter Review

Description Jonathan Kew (:jfkthame) 2011-04-27 06:18:32 PDT
Created attachment 528577 [details] [diff] [review]
patch, remove code to save copies of layout tables prior to OTS sanitization

Since bug 643460 landed, we no longer need to cache the OpenType tables from downloaded fonts, bypassing the sanitizer; the tables will remain in the main sfnt structure (unless they're invalid). So we can trim out the code that was responsible for squirrelling away a copy of the tables prior to sanitization.
Comment 1 Jonathan Kew (:jfkthame) 2011-04-27 22:41:06 PDT
Created attachment 528794 [details] [diff] [review]
patch, remove code to save copies of layout tables prior to OTS sanitization - merged to tip

Updated patch to current m-c tip.
Comment 2 John Daggett (:jtd) 2011-04-27 22:48:10 PDT
Comment on attachment 528794 [details] [diff] [review]
patch, remove code to save copies of layout tables prior to OTS sanitization - merged to tip

Excellent!!
Comment 3 Jonathan Kew (:jfkthame) 2011-04-28 01:07:43 PDT
http://hg.mozilla.org/mozilla-central/rev/52b6489a3140
Comment 4 Jonathan Kew (:jfkthame) 2011-04-28 05:22:00 PDT
Backed out:
  http://hg.mozilla.org/mozilla-central/rev/7253ba2c9d6b
because it turned reftests orange due to bug 653408.
Comment 5 Jonathan Kew (:jfkthame) 2011-05-02 02:16:45 PDT
Re-landed, hoping it sticks this time:
http://hg.mozilla.org/mozilla-central/rev/b7d79acc2930

Note You need to log in before you can comment on or make changes to this bug.