If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tapping the system back button twice with Edit Bookmark menu open closes the application and forgets previously opened tabs

RESOLVED DUPLICATE of bug 652545

Status

Fennec Graveyard
General
P1
major
RESOLVED DUPLICATE of bug 652545
7 years ago
6 years ago

People

(Reporter: Anna (Waverley), Assigned: mbrubeck)

Tracking

({regression})

Trunk
regression

Details

(Reporter)

Description

7 years ago
Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110428 Firefox/6.0a1 Fennec /6.0a1 

Device: HTC Desire Z (Android 2.2)

1. Launch fennec and load www.cnn.com
2. Pan to the left to show the tab panel.
3. Tap on the bookmark's star -> Edit
4. Press the system back button.
5. Press the system back button.

Expected results:
After step 3, the "Edit Bookmark" dialog menu appears and the VKB pops up.
After step 4, the the VKB should be dismissed.
After step 5, the "Edit Bookmark" dialog menu should be closed.

Actual results:
Step 3 and step 4: PASS
After step 5, the application is closed. One has to launch the application again. Fennec starts with about:home, but there are no tabs from last time.

Updated

7 years ago
Severity: normal → major
tracking-fennec: --- → ?
Priority: -- → P1

Updated

7 years ago
Summary: Tapping the system back button twice closes the application → Tapping the system back button twice with Edit Bookmark menu open closes the application and forgets previously opened tabs

Updated

7 years ago
Keywords: regression, regressionwindow-wanted
Reproducible on a Nexus One with 04/28. 

Opened various sites in multiple tabs, opened the edit bookmark pane, tapped back button on device couple times, Fennec closed. Upon application startup, Fennec couldn't remember my last opened tabs.
When Fennec shuts down, logs show a  
ERROR/JavaBinder(4063): Unknown binder error code. 0xfffffff7
Assignee: nobody → mbrubeck
tracking-fennec: ? → ---
Whiteboard: [fennec-6]
(Assignee)

Comment 3

7 years ago
Pressing "escape" with the Edit Bookmark dialog open causes Fennec to exit even on desktop Linux.  It looks like a clean exit rather than a crash.

I get this warning in a debug build; I don't know if it's related:

WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /home/mbrubeck/src/mozilla/mozilla-central/content/base/src/nsContentUtils.cpp, line 2938
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /home/mbrubeck/src/mozilla/mozilla-central/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /home/mbrubeck/src/mozilla/mozilla-central/content/base/src/nsContentUtils.cpp, line 2938
OS: Android → All
Hardware: ARM → All
(Assignee)

Comment 4

7 years ago
Caused by the same regression as bug 652545, and fixed by the patch there.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 652545
tracking-fennec: --- → 6+
Whiteboard: [fennec-6]
tracking-fennec: 6+ → ---
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.