Connect to Sync dialog shows non-functional ok/cancel buttons

VERIFIED FIXED in Firefox 6

Status

Firefox for Android Graveyard
General
P1
normal
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: aakashd, Assigned: wesj)

Tracking

({regression})

Trunk
Firefox 6
regression

Details

(Whiteboard: [fennec-6])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

7 years ago
Created attachment 528106 [details]
bug screenshot

Build id:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:6.0a1) Gecko/20110425 Firefox/6.0a1 Fennec/6.0a1 ID:20110425052833

Note: You need to be disconnected from sync

Steps to Reproduce:
1. Go to the preferences pane
2. Under "Sync", click on the "Connect" button.

Actual Results:
There are non-functional ok/cancel buttons at the bottom of the dialog.

Expected Results:
The ok/cancel buttons don't show up on the dialog.
tracking-fennec: --- → ?

Updated

7 years ago
Keywords: regressionwindow-wanted
Assignee: nobody → wjohnston
tracking-fennec: ? → ---
Whiteboard: [fennec-6]
(Assignee)

Comment 1

7 years ago
Created attachment 528672 [details] [diff] [review]
Patch

This was my fault for the change in Bug 652157. These dialogs are currently picking up a toolkit binding.
(Assignee)

Comment 2

7 years ago
Created attachment 528674 [details] [diff] [review]
Patch v1

And this is the correct patch
Attachment #528672 - Attachment is obsolete: true
Attachment #528674 - Flags: review?(mark.finkle)
Comment on attachment 528674 [details] [diff] [review]
Patch v1


>+dialog.content-dialog {
>+  -moz-binding: none;
>+}

add a comment above this to let us know we want to kill the default binding as well
Attachment #528674 - Flags: review?(mark.finkle) → review+
Blocks: 652157
Keywords: regressionwindow-wanted
Duplicate of this bug: 653413
(Assignee)

Comment 5

7 years ago
pushed: http://hg.mozilla.org/mozilla-central/rev/58abb421e04f
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 6

Comment 6

7 years ago
VERIFIED FIXED on: 
Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110429 Firefox/6.0a1 Fennec /6.0a1 

Device: HTC Desire Z (Android 2.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.