Closed Bug 653913 Opened 11 years ago Closed 2 months ago

When switching tabs between Mail and News, the toolbar doesn't change until a change of folder or newsgroup

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86_64
Linux
defect
Not set
minor

Tracking

(seamonkey2.53+ fixed)

RESOLVED FIXED
seamonkey 2.90
Tracking Status
seamonkey2.53 + fixed

People

(Reporter: tonymec, Assigned: iannbugzilla)

References

Details

(Whiteboard: SM2.53.9)

Attachments

(1 file)

Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110417 Firefox/6.0a1 SeaMonkey/2.2a1pre ID:20110417003006

Reproducible: Always

Open a Mail folder in one 3-pane tab and a Newsgroup in a different 3-pane tab in the same window.

When going from News to Mail by clicking the tab, the "Delete" button in the toolbar does not appear until I select a different Folder in the left pane.

When going from Mail to News by clicking the tab, it doesn't disappear until I select a different Newsgroup in the left pane.
The command updater seems to be working, but the selected folder in the visible tab doesn't seem to be selected properly so the command updater isn't called.
Duplicate of this bug: 688936

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: Delete button vanishes / Reply All button has wrong options
Testing completed (on m-c, etc.): 2.53.10
Risk to taking this patch (and alternatives if risky): low
String changes made by this patch: none

Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #9237381 - Flags: review?(frgrahl)
Attachment #9237381 - Flags: approval-comm-release?
Attachment #9237381 - Flags: approval-comm-esr60?

Comment on attachment 9237381 [details] [diff] [review]
653913-tabmailbuttons-25310.patch

LGTM

Simple fix so lets take it into 2.53.9 as suggested

Attachment #9237381 - Flags: review?(frgrahl)
Attachment #9237381 - Flags: review+
Attachment #9237381 - Flags: approval-comm-release?
Attachment #9237381 - Flags: approval-comm-release+
Attachment #9237381 - Flags: approval-comm-esr60?
Attachment #9237381 - Flags: approval-comm-esr60+
Whiteboard: SM2.53.9

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/8bb8cff837ae
When switching tabs between Mail and News, the toolbar doesn't change until a change of folder or newsgroup. r=frg

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.90

https://gitlab.com/seamonkey-project/seamonkey-2.53-comm/-/commit/a52d02a75332a25f08423d1857f969ebed33f429
When switching tabs between Mail and News, the toolbar doesn't change until a change of folder or newsgroup. r=frg a=frg

You need to log in before you can comment on or make changes to this bug.