Last Comment Bug 654056 - Build IPC support for mips, hppa, ia64, s390(x), powerpc64 and sparc
: Build IPC support for mips, hppa, ia64, s390(x), powerpc64 and sparc
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: IPC (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: mozilla10
Assigned To: Mike Hommey [:glandium]
:
: [PTO to Dec5] Bill McCloskey (:billm)
Mentors:
: 668460 (view as bug list)
Depends on:
Blocks: 683879
  Show dependency treegraph
 
Reported: 2011-05-02 00:43 PDT by Mike Hommey [:glandium]
Modified: 2012-08-29 14:45 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Allow IPC to build on these architectures (2.04 KB, patch)
2011-05-02 00:43 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Add IPC support for mips, hppa, ia64, s390(x), powerpc64 and sparc(64) (2.64 KB, patch)
2011-06-30 01:27 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
fix little-endian assumption in data_pack.cc (3.48 KB, patch)
2011-06-30 03:52 PDT, Dan Horák
no flags Details | Diff | Splinter Review
Build IPC support for mips, hppa, ia64, s390(x), powerpc64 and sparc (2.54 KB, patch)
2011-09-30 02:53 PDT, Mike Hommey [:glandium]
benjamin: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-05-02 00:43:30 PDT
Created attachment 529427 [details] [diff] [review]
Allow IPC to build on these architectures

The patch I'm attaching makes things build.

ia64 has a broken jsengine because of the new jsval, I haven't tested hppa, and I know for a fact that it doesn't actually work on mips and s390, so it's a WIP.

Note that on s390, size_t is defined as unsigned long, which explains the ipc_message_utils.h change.
Comment 1 Mike Hommey [:glandium] 2011-06-30 01:13:13 PDT
*** Bug 668460 has been marked as a duplicate of this bug. ***
Comment 2 Mike Hommey [:glandium] 2011-06-30 01:27:38 PDT
Created attachment 543088 [details] [diff] [review]
Add IPC support for mips, hppa, ia64, s390(x), powerpc64 and sparc(64)
Comment 3 Dan Horák 2011-06-30 03:52:40 PDT
Created attachment 543098 [details] [diff] [review]
fix little-endian assumption in data_pack.cc

This patch makes the work with the resource files endian-independent. It builds fine on x86_64 and s390x, but I don't know how to test it or whether it's even required besides the fact that build fails on big endian arch.
Comment 4 Mike Hommey [:glandium] 2011-06-30 04:14:56 PDT
(In reply to comment #3)
> Created attachment 543098 [details] [diff] [review] [review]
> fix little-endian assumption in data_pack.cc
> 
> This patch makes the work with the resource files endian-independent. It
> builds fine on x86_64 and s390x, but I don't know how to test it or whether
> it's even required besides the fact that build fails on big endian arch.

That file is not built anymore, as it was not used at all. See bug 643112.
Comment 5 Mike Hommey [:glandium] 2011-09-30 02:53:17 PDT
Created attachment 563704 [details] [diff] [review]
Build IPC support for mips, hppa, ia64, s390(x), powerpc64 and sparc

Let's already get this in the tree and file separate bugs for runtime issues

Note You need to log in before you can comment on or make changes to this bug.