Closed Bug 654116 Opened 9 years ago Closed 9 years ago

need pidfile generated for xpcshell process

Categories

(Testing :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bear, Assigned: jmaher)

References

Details

(Whiteboard: [android][tegra])

Attachments

(1 file, 1 obsolete file)

in bug 650828 we generated pidfiles for the parent process runtestsremote but i'm finding instances of xpcshell that are still running even after the parent has been cleaned up.  Since the parent of xpcshell is gone, the ppid returned for xpcshell is 1 so it's never found by my code that walks the parent/child list.

We need to generate a pidfile for xpcshell also so I can clean it up if required.
Whiteboard: [android][tegra]
Blocks: 609536
this patch is tested locally and when using '--pidfile filename', we create filename and filename.xpcshell.
Assignee: nobody → jmaher
Attachment #529747 - Flags: review?(bear)
Comment on attachment 529747 [details] [diff] [review]
add a --pidfile {filename}.xpcshell (1.0)

any reason your ending the file without ".pid" ?  Not a show stopper for this but would love if .pid was the final part after .xpcshell
Attachment #529747 - Flags: review?(bear) → review+
updated patch to have .xpcshell.pid extension
Attachment #529747 - Attachment is obsolete: true
Attachment #529778 - Flags: review+
Blocks: 654756
Patch is working great in staging and I have filed bug 654756 to track the change needed on the Tegra side.  Once that has landed you can land this patch as soon as possible.
http://hg.mozilla.org/mozilla-central/rev/6a34c2c9b880
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Component: New Frameworks → General
You need to log in before you can comment on or make changes to this bug.