Last Comment Bug 654131 - Firefox 4 update/installer failed to scrub old java extensions
: Firefox 4 update/installer failed to scrub old java extensions
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Installer (show other bugs)
: 4.0 Branch
: x86 Windows Vista
: -- normal (vote)
: Firefox 8
Assigned To: Robert Strong [:rstrong] (use needinfo to contact me)
:
Mentors:
Depends on:
Blocks: 597235
  Show dependency treegraph
 
Reported: 2011-05-02 09:16 PDT by timeless
Modified: 2011-08-25 14:39 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
4.0 log (8.01 KB, text/plain)
2011-05-02 09:34 PDT, timeless
no flags Details
listing of files in C:\Program Files\Mozilla Firefox\extensions (18.19 KB, text/plain)
2011-05-02 09:38 PDT, timeless
no flags Details
active Java Console GUIDs (11.49 KB, text/html)
2011-07-28 14:59 PDT, Justin Scott [:fligtar]
no flags Details
patch (13.24 KB, patch)
2011-08-03 16:06 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
jmathies: review+
Details | Diff | Review

Description timeless 2011-05-02 09:16:17 PDT
bug 597235 was supposed to deal with this....

I'm visiting a work computer, it has the following in
C:\Program Files\Mozilla Firefox\extensions:
{CAFEEFAC-0016-0000-0017-ABCDEFFEDCBA}
{CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}
{CAFEEFAC-0016-0000-0023-ABCDEFFEDCBA}
{CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}
(as well as .net framework and skype extensions...)

these are apparently u17, u20, u23, and u24. only u24 should be present - it isn't current, but it's the latest one installed on this system.

  Application Basics
        Name
        Firefox

        Version
        4.0

        User Agent
        Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

  Extensions

        Name

        Version

        Enabled

        ID

        Microsoft .NET Framework Assistant
        1.2.1
        false
        {20a82645-c095-46ed-80e3-08825760534b}

        Skype extension
        5.0.0.6906
        false
        {AB2CE124-6272-4b12-94A9-7303C7397BD1}

        Java Console
        6.0.17
        true
        {CAFEEFAC-0016-0000-0017-ABCDEFFEDCBA}

        Java Console
        6.0.20
        true
        {CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}

        Java Console
        6.0.23
        true
        {CAFEEFAC-0016-0000-0023-ABCDEFFEDCBA}

        Java Console
        6.0.24
        true
        {CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}

I was asked to file this bug by someone in mozilla.public.dev-planning. I will not have access to this computer in the future.

If there's a mozilla installer/updater log file that should be collected, please indicate it ASAP or else it is unlikely that anyone will be able to retrieve it. I believe this was an update via the menu from firefox3.6.x.

for internal reference, this is the team Skype computer.
Comment 1 Robert Strong [:rstrong] (use needinfo to contact me) 2011-05-02 09:21:23 PDT
Thanks timeless, could you check if there is an uninstall.log file in the uninstall directory?
Comment 2 timeless 2011-05-02 09:34:32 PDT
Created attachment 529493 [details]
4.0 log
Comment 3 timeless 2011-05-02 09:38:53 PDT
Created attachment 529494 [details]
listing of files in C:\Program Files\Mozilla Firefox\extensions
Comment 4 Robert Strong [:rstrong] (use needinfo to contact me) 2011-05-02 09:41:04 PDT
To check the post update cleanup of the files run cmd.exe as admin, cd into <firefox install dir>\uninstall\, and run helper.exe /PostUpdate.
Comment 5 timeless 2011-05-02 09:46:13 PDT
I did that, nothing happened / no files were deleted....
Comment 6 Robert Strong [:rstrong] (use needinfo to contact me) 2011-05-02 21:13:24 PDT
Thanks, it appears that dir paths can no longer end with a \... pretty sure it worked back when we used NSIS 2.22. Before I submit a patch I'm going to audit usage.
Comment 7 Dave Townsend [:mossop] 2011-06-21 15:12:24 PDT
Bug 659772 also says the console can also exist with ID {CAFEEFAC-0016-0000-0026-ABCDEFFEDCBA}.
Comment 8 Justin Scott [:fligtar] 2011-07-24 22:14:23 PDT
I can confirm that there are more than 76 million installations of Java Console in Firefox 4 and later. This bug is fairly important, as these add-ons are likely not compatible and users may be reluctant to upgrade thinking they are losing functionality.

If you need an updated list of GUIDs, let me know.
Comment 9 Dão Gottwald [:dao] 2011-07-25 01:29:58 PDT
(In reply to comment #8)
> I can confirm that there are more than 76 million installations of Java
> Console in Firefox 4 and later. This bug is fairly important, as these
> add-ons are likely not compatible and users may be reluctant to upgrade
> thinking they are losing functionality.

-> requesting tracking-firefox6 (our next update)
Comment 10 Justin Scott [:fligtar] 2011-07-28 14:59:58 PDT
Created attachment 549236 [details]
active Java Console GUIDs

These are all of the active Java Console GUIDs.
Comment 11 Robert Strong [:rstrong] (use needinfo to contact me) 2011-08-03 16:06:36 PDT
Created attachment 550544 [details] [diff] [review]
patch

Jim, turns out that the check if a dir exists will fail if the path ends in a slash. :( Reminds me of how stat will return ENOENT when checking a dir path that ends with a slash. This also adds a couple of new java console extensions to the list that have a large number of users.
Comment 12 Jim Mathies [:jimm] 2011-08-08 09:06:56 PDT
Comment on attachment 550544 [details] [diff] [review]
patch

I hate these things, they are so annoying!
Comment 13 Robert Strong [:rstrong] (use needinfo to contact me) 2011-08-08 21:00:35 PDT
Pushed to fx-team
http://hg.mozilla.org/integration/fx-team/rev/ec8abe32a3a5
Comment 14 Tim Taubert [:ttaubert] 2011-08-09 09:09:24 PDT
http://hg.mozilla.org/mozilla-central/rev/ec8abe32a3a5
Comment 15 Christopher Blizzard (:blizzard) 2011-08-25 14:39:32 PDT
Unmarking tracking for 8 since this made the uplift.

Note You need to log in before you can comment on or make changes to this bug.