Unable to reuse IDs for deleted self hosted addons

RESOLVED FIXED in 6.0.12

Status

addons.mozilla.org Graveyard
Administration
P3
normal
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: mkaply, Assigned: andym)

Tracking

unspecified
6.0.12

Details

(Reporter)

Description

7 years ago
My understanding was that as part of this bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=636834

all remnants of our self hosted addons were going to be removed from the system.

We recently decided to make a few of our old self hosted addons AMO hosted, but we are getting a "duplicate ID" error.

So these things still exist in the system somewhere.

the ones we ran into were 

ctrlaltdelboom@cad-comic.com and godukeboom@goduke.com

Not sure what the right thing to do is here.
Are there any GUIDs besides those 2 you need removed from the submission blacklist?
Summary: Unable to reuse IDs for deleted self hsoted addons → Unable to reuse IDs for deleted self hosted addons
(Reporter)

Comment 2

7 years ago
Yes. It will happen over time as we see which have enough users to want us to put them on AMO as well.

weatherboom@brandthunder.com comes to mind.

What is this submission blacklist?

I didn't realize this would be a consequence of removing the self hosted stuff from our list.
Any time an add-on is deleted from AMO we add its guid to a blacklist. This is because most add-ons have active users that will continue to ping AMO, and someone else could submit that add-on's GUID and steal those users.

If you'd like me to remove all @brandthunder.com entries I can do that, or I can just remove these 3. But I don't want to remove them one at a time every few weeks, so please let me know which you'd prefer.
(Reporter)

Comment 4

7 years ago
I guess a better question then is why self hosted addons relied on GUIDs at all, since the XPI wasn't hosted on AMO and no statistics were gathered.

Separate issue though.

Not all the IDs will end in @brandthunder.com, so it's not easy to find them all. But yes, the easiest place to start would be to remove the ones I referenced and all @brandthunder.com entries.

thanks
Removed these GUIDs:

    Blacklisted guid: umespersona@brandthunder.com
    Blacklisted guid: vanderbiltupersona@brandthunder.com
    Blacklisted guid: michiganstupersona@brandthunder.com
    Blacklisted guid: acconfpersona@brandthunder.com
    Blacklisted guid: uofarizonapersona@brandthunder.com
    Blacklisted guid: uofcincinnatipersona@brandthunder.com
    Blacklisted guid: texastechupersona@brandthunder.com
    Blacklisted guid: uofkansaspersona@brandthunder.com
    Blacklisted guid: uofpittsburghpersona@brandthunder.com
    Blacklisted guid: uofgeorgiapersona@brandthunder.com
    Blacklisted guid: halloween2010persona@brandthunder.com
    Blacklisted guid: halloweenpersona@brandthunder.com
    Blacklisted guid: uofscarolinapersona@brandthunder.com
    Blacklisted guid: auburnupersona@brandthunder.com
    Blacklisted guid: georgetownupersona@brandthunder.com
    Blacklisted guid: ncstateupersona@brandthunder.com
    Blacklisted guid: uofmissouripersona@brandthunder.com
    Blacklisted guid: uoftennesseepersona@brandthunder.com
    Blacklisted guid: washingtonstupersona@brandthunder.com
    Blacklisted guid: uofnotredamepersona@brandthunder.com
    Blacklisted guid: nasapersona@brandthunder.com
    Blacklisted guid: uofmichiganpersona@brandthunder.com
    Blacklisted guid: villanovaupersona@brandthunder.com
    Blacklisted guid: uofillinoispersona@brandthunder.com
    Blacklisted guid: oklahomastupersona@brandthunder.com
    Blacklisted guid: uofwisconsinpersona@brandthunder.com
    Blacklisted guid: uofwashingtonpersona@brandthunder.com
    Blacklisted guid: uclapersona@brandthunder.com
    Blacklisted guid: arizonastupersona@brandthunder.com
    Blacklisted guid: uofncarolinapersona@brandthunder.com
    Blacklisted guid: bigtenconfpersona@brandthunder.com
    Blacklisted guid: indianaupersona@brandthunder.com
    Blacklisted guid: purdueupersona@brandthunder.com
    Blacklisted guid: pennstupersona@brandthunder.com
    Blacklisted guid: uoflouisvillepersona@brandthunder.com
    Blacklisted guid: marquetteupersona@brandthunder.com
    Blacklisted guid: uofiowapersona@brandthunder.com
    Blacklisted guid: wakeforestunivpersona@brandthunder.com
    Blacklisted guid: stanfordupersona@brandthunder.com
    Blacklisted guid: providencecollpersona@brandthunder.com
    Blacklisted guid: kansasstupersona@brandthunder.com
    Blacklisted guid: uoftexaspersona@brandthunder.com
    Blacklisted guid: uofcaliforniapersona@brandthunder.com
    Blacklisted guid: oregonstupersona@brandthunder.com
    Blacklisted guid: gatechpersona@brandthunder.com
    Blacklisted guid: depaulupersona@brandthunder.com
    Blacklisted guid: uofalabamapersona@brandthunder.com
    Blacklisted guid: stjohnsupersona@brandthunder.com
    Blacklisted guid: uofmiamipersona@brandthunder.com
    Blacklisted guid: flastatepersona@brandthunder.com
    Blacklisted guid: uofconnecticutpersona@brandthunder.com
    Blacklisted guid: uofoklahomapersona@brandthunder.com
    Blacklisted guid: baylorupersona@brandthunder.com
    Blacklisted guid: stackpersona@brandthunder.com
    Blacklisted guid: askmenboom@askmen.com
    Blacklisted guid: uscpersona@brandthunder.com
    Blacklisted guid: redbullspersona@brandthunder.com
    Blacklisted guid: huffpostpersona@brandthunder.com
    Blacklisted guid: mlsunionpersona@brandthunder.com
    Blacklisted guid: goblinspersona2@brandthunder.com
    Blacklisted guid: ignboom@ign.com
    Blacklisted guid: fantasyrpgtheme@brandthunder.com
    Blacklisted guid: dragontheme@brandthunder.com
    Blacklisted guid: animetheme@brandthunder.com
    Blacklisted guid: sanjeevkapoorboom@sanjeevkapoor.com
    Blacklisted guid: godukeboom@goduke.com
    Blacklisted guid: nbakingsboom@nba.com
    Blacklisted guid: prowrestlingboom@brandthunder.com
    Blacklisted guid: plaidthemetheme@brandthunder.com
    Blacklisted guid: fleurdelistheme@brandthunder.com
    Blacklisted guid: snowthemetheme@brandthunder.com
    Blacklisted guid: transparenttheme@brandthunder.com
    Blacklisted guid: nauticaltheme@brandthunder.com
    Blacklisted guid: sierrasunsettheme@brandthunder.com
    Blacklisted guid: hotgirlbodytheme@brandthunder.com
    Blacklisted guid: ctrlaltdelboom@cad-comic.com
    Blacklisted guid: cricketboom@brandthunder.com
    Blacklisted guid: starrynighttheme@brandthunder.com
    Blacklisted guid: fantasyflowertheme@brandthunder.com
    Blacklisted guid: militarycamotheme@brandthunder.com
    Blacklisted guid: paristhemetheme@brandthunder.com
    Blacklisted guid: greatwalltheme@brandthunder.com
    Blacklisted guid: motorcycle@brandthunder.com
    Blacklisted guid: fullspeedboom@fullspeed2acure.com
    Blacklisted guid: waterfalls@brandthunder.com
    Blacklisted guid: mothersday2010boom@brandthunder.com
    Blacklisted guid: pyramids@brandthunder.com
    Blacklisted guid: mountain@brandthunder.com
    Blacklisted guid: beachsunset@brandthunder.com
    Blacklisted guid: newyorkcity@brandthunder.com
    Blacklisted guid: shinymetal@brandthunder.com
    Blacklisted guid: moviepremiereboom@brandthunder.com
    Blacklisted guid: kitttens@brandthunder.com
    Blacklisted guid: tulips@brandthunder.com
    Blacklisted guid: aquarium@brandthunde.com
    Blacklisted guid: wood@brandthunder.com
    Blacklisted guid: puppies@brandthunder.com
    Blacklisted guid: ouaboom@oua.ca
    Blacklisted guid: wibwboom@wibw.com
    Blacklisted guid: nasasettingsun@brandthunder.com
    Blacklisted guid: bluesky@brandthunder.com
    Blacklisted guid: cheerleaders@brandthunder.com
    Blacklisted guid: greengrass@brandthunder.com
    Blacklisted guid: crayonpinktheme@brandthunder.com
    Blacklisted guid: crayonredtheme@brandthunder.com
    Blacklisted guid: crayonyellow@brandthunder.com
    Blacklisted guid: crayongreen@brandthunder.com
    Blacklisted guid: crayonblue@brandthunder.com
    Blacklisted guid: weatherboom@brandthunder.com
    Blacklisted guid: crayonblack@brandthunder.com
    Blacklisted guid: ambientglow@brandthunder.com
    Blacklisted guid: bubbles@brandthunder.com
    Blacklisted guid: matrixcode@brandthunder.com
    Blacklisted guid: firetheme@brandthunder.com
    Blacklisted guid: neonlights@brandthunder.com
    Blacklisted guid: brushedmetal@brandthunder.com
    Blacklisted guid: sugarland2@brandthunder.com
    Blacklisted guid: suns2@brandthunder.com
    Blacklisted guid: thanksgiving2@brandthunder.com
    Blacklisted guid: ecoboom2@brandthunder.com
    Blacklisted guid: thanksgivingboom@brandthunder.com
Assignee: nobody → fligtar
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

7 years ago
Will this take some time to mirror? We're still unable to submit the addons.
(Reporter)

Comment 7

7 years ago
We're still unable to submit using any of these IDs
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Huh, it seems the self-hosted add-ons were only disabled so they're still in the add-ons table, yet they were also somehow added to the blacklisted guids table as though they were deleted.

This will need a dev to figure out what's going on.
Assignee: fligtar → nobody
(Reporter)

Comment 9

7 years ago
This is starting to seriously impact us. Who is a dev that could investigate?
Dave wrote the script in bug 636834 - Dave, can you shed any light on this?
(Reporter)

Comment 11

7 years ago
This is impacting our business. Can someone please take a look?
Severity: normal → blocker
Dave is out this week.  Andy, could you see what happened when that script ran?
Assignee: nobody → amckay
Severity: blocker → normal
Priority: -- → P3
Target Milestone: --- → 6.0.12
(Assignee)

Comment 13

7 years ago
I was not able to reproduce getting the addons into this state and there isn't anything in the logs. In preview we've got some blacklisted guids and some of the addons. 

So I've gone for the brute force approach and created a script that deletes all guids mentioned above. Then delete's all the addons, then delete's all the guids again. When run we should end up with a db with none of the listed guids or addons in them.

https://github.com/jbalogh/zamboni/commit/34b7fa233e673c71b8d445872d970ebfeeeb85a4
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

7 years ago
How soon will this happen?

We're still unable to use these IDs.
It'll go out next Thursday
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.