Last Comment Bug 654170 - Make js_InitArrayClass non-generic
: Make js_InitArrayClass non-generic
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-02 11:01 PDT by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2011-07-19 08:12 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (3.11 KB, patch)
2011-05-02 11:01 PDT, Jeff Walden [:Waldo] (remove +bmo to email)
no flags Details | Diff | Splinter Review
Updated patch (4.86 KB, patch)
2011-07-12 17:32 PDT, Jeff Walden [:Waldo] (remove +bmo to email)
bhackett1024: review+
Details | Diff | Splinter Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2011-05-02 11:01:30 PDT
Created attachment 529516 [details] [diff] [review]
Patch

Another step toward making bootstrapping special.  This also happens to fix the long-standing bug 592296.  \o/

I'm continuing to stick with jorendorff because he's reviewed the other de-generifying patches.  Note that Array has some special-case handling in js_InitClass which makes this slightly more complicated than RegExp and String were, although not too horribly tricky.

In theory I could remove the Array-specific complexity from js_InitClass now, but it seems better to leave that for a final cleanup once all standard-class initialization is made special.
Comment 1 Jason Orendorff [:jorendorff] 2011-06-24 07:07:43 PDT
Comment on attachment 529516 [details] [diff] [review]
Patch

Clearing the review bit since I r-'d all the patches along these lines, and Jeff has a new approach that I'm going to be reviewing today.
Comment 2 Jeff Walden [:Waldo] (remove +bmo to email) 2011-07-12 17:32:19 PDT
Created attachment 545547 [details] [diff] [review]
Updated patch

This builds on a bunch of the minor abstractions you've already reviewed, or will be reviewing.  It also consolidates some of the old code a bit, now that Array's special-casing has been removed from the general code path.  The comments indicate why more special-casing can't yet be removed, and what needs to be done to do so.
Comment 3 Brian Hackett (:bhackett) 2011-07-15 10:00:06 PDT
Comment on attachment 545547 [details] [diff] [review]
Updated patch

Review of attachment 545547 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 4 Joe Drew (not getting mail) 2011-07-16 18:46:14 PDT
This (along with most things committed on Friday afternoon) was backed out of mozilla-inbound in order to clear up orange.
Comment 5 Jeff Walden [:Waldo] (remove +bmo to email) 2011-07-18 14:48:35 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/ada72f2e38df
Comment 6 Marco Bonardo [::mak] 2011-07-19 08:12:10 PDT
http://hg.mozilla.org/mozilla-central/rev/ada72f2e38df

Note You need to log in before you can comment on or make changes to this bug.