Not able to display Japanese menus and menu items.

VERIFIED DUPLICATE of bug 7822

Status

()

Core
Internationalization
P3
major
VERIFIED DUPLICATE of bug 7822
19 years ago
18 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: saari (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
** Observed wirh 5/13/99 Linux 5.0 build **

I ran the above Linux build under all the Japanese locales
I could find under RH 5.2 installation with the navigator.xul
file's menu and menu items translated into Japanese and
then converted to UTF-8. I tried the following locales.

ja_JP.EUC
ja_JP.UJIS (actually not listed as one of the locales on my machine, mugen)
japanese


What I saw instead of Japanese were Latin characters.
I guess we are not using the correct fonts for the locales
above. We should at least get Japanese display working
under a Japanese locale.

One other thing I would try next would be other possible
locale names. (I don't think I have exhausted the names yet.)

Also what I cannot rule out yet is that my CDE environment may
need an Japanization patch.

Thus I'm not sure if this is our bug or the lack of proper
Japanese environment setup. In any case, I'm filing this bug
to keep track of this problem.

Updated

19 years ago
Assignee: ftang → trudelle

Comment 1

19 years ago
one solutions -use GFX base menu and menu bar to draw the text of the widget
Hand this to trudelle unless he need our group to help. This is a native widget
issue. It happend to Mac window and GTK.
(Reporter)

Comment 2

19 years ago
I also test under:

LANG = ja_JP.ujis

and it does not work. This is teh locale under which the display should be working when fixed.

Updated

19 years ago
Assignee: trudelle → saari

Comment 3

19 years ago
reassigning to saari
(Assignee)

Updated

18 years ago
Target Milestone: M7

Updated

18 years ago
Blocks: 7228
(Assignee)

Updated

18 years ago
Target Milestone: M7 → M8
(Assignee)

Comment 4

18 years ago
GTK is hosed for internationalization until version 1.4 or so, and the Mac has
been tackled by Tague, so it should work now. In any case, I'm pushing this to
M8.

Comment 5

18 years ago
Actually, I fixed this bug. It is a dup of

  http://bugzilla.mozilla.org/show_bug.cgi?id=7822

Comment 6

18 years ago
So, should this be made a DUP.  Or are we leaving this open for the multilingual
support?

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
This bug started out as a pure Japanese locale menu bug, so let's keep it that
way. If we want a bug report for the multilingual menus, let's create another
one and keep it pure too. Marking this one a DUP.

*** This bug has been marked as a duplicate of 7822 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 8

18 years ago
Verified as dup.

Updated

18 years ago
Blocks: 18471

Updated

17 years ago
No longer blocks: 18471
You need to log in before you can comment on or make changes to this bug.