Last Comment Bug 6542 - Not able to display Japanese menus and menu items.
: Not able to display Japanese menus and menu items.
Status: VERIFIED DUPLICATE of bug 7822
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: x86 Linux
: P3 major (vote)
: M8
Assigned To: saari (gone)
: Teruko Kobayashi
:
Mentors:
Depends on:
Blocks: 7228
  Show dependency treegraph
 
Reported: 1999-05-17 00:55 PDT by Katsuhiko Momoi
Modified: 1999-07-06 14:16 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Katsuhiko Momoi 1999-05-17 00:55:57 PDT
** Observed wirh 5/13/99 Linux 5.0 build **

I ran the above Linux build under all the Japanese locales
I could find under RH 5.2 installation with the navigator.xul
file's menu and menu items translated into Japanese and
then converted to UTF-8. I tried the following locales.

ja_JP.EUC
ja_JP.UJIS (actually not listed as one of the locales on my machine, mugen)
japanese


What I saw instead of Japanese were Latin characters.
I guess we are not using the correct fonts for the locales
above. We should at least get Japanese display working
under a Japanese locale.

One other thing I would try next would be other possible
locale names. (I don't think I have exhausted the names yet.)

Also what I cannot rule out yet is that my CDE environment may
need an Japanization patch.

Thus I'm not sure if this is our bug or the lack of proper
Japanese environment setup. In any case, I'm filing this bug
to keep track of this problem.
Comment 1 Frank Tang 1999-05-18 17:11:59 PDT
one solutions -use GFX base menu and menu bar to draw the text of the widget
Hand this to trudelle unless he need our group to help. This is a native widget
issue. It happend to Mac window and GTK.
Comment 2 Katsuhiko Momoi 1999-05-18 18:09:59 PDT
I also test under:

LANG = ja_JP.ujis

and it does not work. This is teh locale under which the display should be working when fixed.
Comment 3 Peter Trudelle 1999-05-19 13:52:59 PDT
reassigning to saari
Comment 4 saari (gone) 1999-06-15 14:40:59 PDT
GTK is hosed for internationalization until version 1.4 or so, and the Mac has
been tackled by Tague, so it should work now. In any case, I'm pushing this to
M8.
Comment 5 Erik van der Poel 1999-06-15 18:55:59 PDT
Actually, I fixed this bug. It is a dup of

  http://bugzilla.mozilla.org/show_bug.cgi?id=7822
Comment 6 bobj 1999-06-16 01:34:59 PDT
So, should this be made a DUP.  Or are we leaving this open for the multilingual
support?
Comment 7 Erik van der Poel 1999-06-16 09:46:59 PDT
This bug started out as a pure Japanese locale menu bug, so let's keep it that
way. If we want a bug report for the multilingual menus, let's create another
one and keep it pure too. Marking this one a DUP.

*** This bug has been marked as a duplicate of 7822 ***
Comment 8 Teruko Kobayashi 1999-07-06 14:16:59 PDT
Verified as dup.

Note You need to log in before you can comment on or make changes to this bug.