Last Comment Bug 654372 - nsWebBrowserPersist init list out of order - "warning: 'nsWebBrowserPersist::mWrapColumn' will be initialized after ... 'PRInt64 nsWebBrowserPersist::mTotalCurrentProgress' ... when initialized here (nsWebBrowserPersist.cpp:234)"
: nsWebBrowserPersist init list out of order - "warning: 'nsWebBrowserPersist::...
Status: RESOLVED FIXED
[build_warning]
:
Product: Core
Classification: Components
Component: Embedding: APIs (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th)
:
Mentors:
http://tinderbox.mozilla.org/showlog....
Depends on:
Blocks: 646071
  Show dependency treegraph
 
Reported: 2011-05-02 23:10 PDT by Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th)
Modified: 2011-05-04 01:31 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.00 KB, patch)
2011-05-02 23:14 PDT, Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th)
ehsan: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2011-05-02 23:10:29 PDT
nsWebBrowserPersist's init list is out of order since this cset:
  http://hg.mozilla.org/mozilla-central/rev/b7bfd0871b3f

The build warning is:
nsWebBrowserPersist.h: In constructor 'nsWebBrowserPersist::nsWebBrowserPersist()':
nsWebBrowserPersist.h:244:31: warning: 'nsWebBrowserPersist::mWrapColumn' will be initialized after
nsWebBrowserPersist.h:242:31: warning:   'PRInt64 nsWebBrowserPersist::mTotalCurrentProgress'
nsWebBrowserPersist.cpp:234:1: warning:   when initialized here
Comment 1 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2011-05-02 23:14:25 PDT
Created attachment 529641 [details] [diff] [review]
fix
Comment 2 :Ehsan Akhgari 2011-05-03 11:00:48 PDT
Comment on attachment 529641 [details] [diff] [review]
fix

Sorry!  In my defense, I *tried* to preserve the correct initialization order!  ;-)
Comment 3 Daniel Holbert [:dholbert] (mostly OOTO until Aug 9th) 2011-05-03 16:47:13 PDT
No problem. :)

Adding checkin-needed keyword, in the hopes that this can ride along with something.  (Patch already has author & commit message set correctly, so it can be hg [q]imported)
Comment 4 Dão Gottwald [:dao] 2011-05-04 01:31:41 PDT
http://hg.mozilla.org/mozilla-central/rev/759cb9d29ef3

Note You need to log in before you can comment on or make changes to this bug.