Closed Bug 654402 Opened 9 years ago Closed 9 years ago

"Copies & Folders" page in Account Settings is cut off

Categories

(Thunderbird :: Account Manager, defect)

All
Windows 7
defect
Not set

Tracking

(blocking-thunderbird5.0 beta2+, thunderbird5.0 beta2-fixed, thunderbird6 fixed)

RESOLVED FIXED
Thunderbird 7.0
Tracking Status
blocking-thunderbird5.0 --- beta2+
thunderbird5.0 --- beta2-fixed
thunderbird6 --- fixed

People

(Reporter: ts.bugzilla, Assigned: gkw)

References

Details

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: 

This was reported in bug 607295, the changes introducing a separate "Message Archives" section resulted in the layout being cut off at the bottom - at least on Windows 7. Fortunately the window is resizable, but the default dialog size (or persisted old values) seems to be too small now. See attachment 528421 [details] for a screenshot.

Reproducible: Always
Blocks: 607295
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirming this bug on Windows 7.

Increasing the height value in <!ENTITY accountManager.size "width: 121ch; height: 49em;"> seems to have no effect?
Height should be set to 53em for Win 7.
Alex, can you come up with a patch ?
Component: General → Account Manager
QA Contact: general → account-manager
Attached patch comm-central patch (obsolete) — Splinter Review
Attached patch comm-miramar patch (obsolete) — Splinter Review
Note, XUL cache must be cleared to see the correct new (default) dialog size. Not sure about the necessary window size for Unix / OS X.
Attachment #533299 - Flags: ui-review?(bwinton)
Attachment #533299 - Flags: review?(bwinton)
Assignee: nobody → AlexIhrig
Status: NEW → ASSIGNED
Comment on attachment 533299 [details] [diff] [review]
comm-central patch

Well, the problem still exists on Mac, which seems to need at least 55em, and the uploaded patch doesn't seem to be valid, because hg doesn't handle UTF-16 well, but applying the change manually works for me.

So that leaves me in a really weird spot.  I think I've got to go with ui-r+, but r-.  But I think this patch is really close to working, and the next version will probably just get an r+ from me.  (You can carry forward the ui-r+ from this patch.)

Thanks,
Blake.
Attachment #533299 - Flags: ui-review?(bwinton)
Attachment #533299 - Flags: ui-review+
Attachment #533299 - Flags: review?(bwinton)
Attachment #533299 - Flags: review-
Sorry, maybe someone else could finish this 1-line patch.
Assignee: AlexIhrig → nobody
Status: ASSIGNED → NEW
Yeah, I'll take this.
Attached patch patch v2Splinter Review
Changing to 55em as requested.
Assignee: nobody → gary
Attachment #533299 - Attachment is obsolete: true
Attachment #533300 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #536276 - Flags: review?(bwinton)
Comment on attachment 536276 [details] [diff] [review]
patch v2

Review of attachment 536276 [details] [diff] [review]:
-----------------------------------------------------------------

Looks great!

r=me, with my thanks.
Attachment #536276 - Flags: review?(bwinton) → review+
http://hg.mozilla.org/comm-central/rev/011b3037aa41
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 7.0
blocking-thunderbird5.0: --- → ?
blocking-thunderbird5.0: ? → beta2+
Attachment #536276 - Flags: approval-thunderbird5.0+
Attachment #536276 - Flags: approval-comm-aurora?
Attachment #536276 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.