crash when window closed before OKing "load image?"

VERIFIED DUPLICATE of bug 57188

Status

()

--
critical
VERIFIED DUPLICATE of bug 57188
18 years ago
16 years ago

People

(Reporter: mcarland, Assigned: morse)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; 0.7) Gecko/20010109
BuildID:    2001010901

Sometimes the "allow image" dialog gets behind the window doing the loading. If
I close the window before the dialog, when I later "OK" the dialog, the
application crashes.

Reproducible: Always
Steps to Reproduce:
Select "Accept all images".
Check "Alert me before downloading an image".
Go to a URL that has images that you have not visited before.
When the "Confirm: The site X wants to load an image. Do you want to allow it?"
appears, drag the original window around. The dialog will fall to the back.
Close the original window.
When you "YES" the Confirm dialog, crash boom baby.


Expected Results:  Dialog should stay in front of window and not allow window to
close until dialog dismissed.

This is pretty obvious to avoid with simple sites and a single window, since the
loading window stops loading when waiting for an answer. When "power surfing",
if a page starts loading and you switch to another while it loads, it is easy to
miss that the dialog ever existed, especially if most of the sites images load
since you have OK'ed images from that site, but a banner ad in a corner comes
from a new web address. I assume the page loaded and the banner ad was skipped
since I had previously denied images from an ad site, but the page has a new ad URL.

Comment 1

18 years ago
Confirming bug, build 2001-01-13-08 on Windows 98 SE.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash

Comment 2

18 years ago
->morse
Assignee: asa → morse
Component: Browser-General → Cookies
QA Contact: doronr → tever
(Assignee)

Comment 3

18 years ago

*** This bug has been marked as a duplicate of 57188 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
verified dup
Status: RESOLVED → VERIFIED

Updated

16 years ago
Component: Cookies → Image Blocking
You need to log in before you can comment on or make changes to this bug.