Bad display of compose window addressing indicators on Mac following bug 642163

RESOLVED FIXED in Thunderbird 5.0b1

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: standard8, Assigned: andreasn)

Tracking

({regression})

Trunk
Thunderbird 5.0b1
All
Mac OS X
regression

Firefox Tracking Flags

(blocking-thunderbird5.0 needed)

Details

(Whiteboard: [not l10n])

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

7 years ago
Created attachment 529699 [details]
Screenshot

See the attached screenshot.

There's two issues here:

1) For some reason the second and third lines have buttons that seem to be slightly taller.
2) The Newsgroup: text is partially obscured (same with Follow-up to: but that isn't shown here).

I'm not sure what is best for the newsgroup text here. Maybe smaller text or a tooltip. Although I'm not convinced a tooltip is really that good for something we should be able to display on the default UI.
I had only one time access to a Mac for the checks. Actually I have no Mac and I can't investigate this strange problem.

About the obscured text: the screenshot shows on the left of Newsgr... more space than the menulist on top (the one after From: ). Maybe it's possible to work with padding/margin. If nothing helps, maybe a new entity in messengercompose.dtd especially for Mac bigger width than for the others can do it.
(Reporter)

Comment 2

7 years ago
I'm not sure I'd want to go for a bigger width - it already feels like there's a whole load of empty space outside those areas.
(Assignee)

Updated

7 years ago
Assignee: nobody → nisses.mail
Created attachment 530127 [details] [diff] [review]
Addressing only the truncated aw-menulist

Standard8 please can you try this patch? I had today the same problem under WinXP by changing aw-menulist to a more native menulist.

Important: this patch don't solve the different height.
Duplicate of this bug: 654916

Comment 5

7 years ago
Richard, I'm going to reopen 654916 as I can reproduce this on other platforms as well, thus it's independent from the Mac-specific menu-width issue here.
Attachment 530862 [details] in Bug 654916 shows the result with both patches applied. The unequal height looks solved, but the truncation not. The menulists are also to high aligned.

Attachment 530865 [details] shows also some problems with the focus ring.

:andreasn, is it okay to address the truncation and the focus ring problems in this Bug, because this is Mac only? I think, the focus ring issue is correlated to the aligning.
(Reporter)

Updated

7 years ago
Whiteboard: [not l10n]
(Assignee)

Comment 7

7 years ago
Richard: Yeah, I think that makes sense to solve that in this bug
(Assignee)

Comment 8

7 years ago
.aw-menulist > .menulist-label {
  font: icon;
  -moz-margin-end: 3px;
  font-size: 10px;
}

Seems like the above does the trick (for newsgroup at least, not for Followup-to yet). I think my qseries is broken, but I'll try and make a patch.
(Assignee)

Comment 9

7 years ago
Created attachment 531291 [details] [diff] [review]
patch fixing trunkation
Andreas: The dropmarker is now on the right side. Before the composer patches it was on the left.

For winXP I used this:

/* set the dropmarker at the beginning of the aw-menulist */
.aw-menulist:-moz-locale-dir(ltr),
.aw-menulist > .menulist-label-box:-moz-locale-dir(rtl) {
  direction: rtl; 
}

.aw-menulist:-moz-locale-dir(rtl),
.aw-menulist > .menulist-label-box:-moz-locale-dir(ltr) {
  direction: ltr; 
}

Maybe this works also for OSX
(Assignee)

Comment 11

7 years ago
Created attachment 531314 [details] [diff] [review]
This should do the trick

* Sets font size to 10px (same as the other widgets)
* Adds Richards padding from attachment 530127 [details] [diff] [review]
* Adds the rtl thing, so all labels become right aligned.
Attachment #531291 - Attachment is obsolete: true
(Assignee)

Comment 12

7 years ago
Created attachment 531315 [details]
screenshot of above patch in action
(Assignee)

Updated

7 years ago
Attachment #531314 - Flags: ui-review?(bwinton)
Attachment #531314 - Flags: review?(mbanner)
Comment on attachment 531314 [details] [diff] [review]
This should do the trick

That looks very nice to me!

Thanks,
Blake.
Attachment #531314 - Flags: ui-review?(bwinton) → ui-review+
(Reporter)

Updated

7 years ago
Attachment #531314 - Flags: review?(mbanner) → review+
(Reporter)

Comment 14

7 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/22fe617c4cbd
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a4
You need to log in before you can comment on or make changes to this bug.